DNS does not work correctly.

Discussion in 'Installation/Configuration' started by TheSzymek, Nov 21, 2018.

Tags:
  1. TheSzymek

    TheSzymek New Member

    Hello, sorry for my broken English, but I write from the translator, because I do not know English well.

    My problem is that my DNS server on the VPS server is not working properly. I installed a new Debian9 system on my VPS. Immediately after this I went to the ISPConfig installation from this link: howtoforge.com/tutorial/ispconfig-automated-install-script. After installing, I added the domain and configured its DNS zone. I have waited over 24 hours, however, the site still does not respond to the address. Below he adds the entire configuration.

    System: Debian9 64bit
    Domain: TheSzymek.GA
    Nameserver's config ---> Domena.PNG
    ISP DNS Zone ---> ISPConfig.PNG
    DNS Zone config ---> DNSZone.PNG
    Dig result's from putty VPS ---> Dig.PNG
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. TheSzymek

    TheSzymek New Member

    Thanks! I just made the configuration according to the guide from the internet and found the lack in your DNS settings. I missed the "A" record for NS servers.

    The domain currently works in the browser but unfortunately not as it should. After entering the address in the bar it shows me the main page of the server (Apache2 debian default page), and not as the default should be from the ISPConfig.
     
  4. Hello,
    It works from there (only asking your server).
    NS are ns3 and ns4, not ns1 ans ns2
    Code:
    dig theszymek.ga ns @80.211.240.30
    
    ; <<>> DiG 9.11.3-1ubuntu1.3-Ubuntu <<>> theszymek.ga ns @80.211.240.30
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52242
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 3
    ;; WARNING: recursion requested but not available
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;theszymek.ga.           IN   NS
    
    ;; ANSWER SECTION:
    theszymek.ga.       86400   IN   NS   ns4.theszymek.ga.
    theszymek.ga.       86400   IN   NS   ns3.theszymek.ga.
    
    ;; ADDITIONAL SECTION:
    ns3.theszymek.ga.   86400   IN   A   80.211.240.30
    ns4.theszymek.ga.   86400   IN   A   80.211.240.30
    
    ;; Query time: 347 msec
    ;; SERVER: 80.211.240.30#53(80.211.240.30)
    ;; WHEN: Thu Nov 22 09:01:04 +11 2018
    ;; MSG SIZE  rcvd: 109
    Code:
    dig theszymek.ga mx @80.211.240.30
    
    ; <<>> DiG 9.11.3-1ubuntu1.3-Ubuntu <<>> theszymek.ga mx @80.211.240.30
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40890
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4
    ;; WARNING: recursion requested but not available
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;theszymek.ga.           IN   MX
    
    ;; ANSWER SECTION:
    theszymek.ga.       86400   IN   MX   10 mail.theszymek.ga.
    
    ;; AUTHORITY SECTION:
    theszymek.ga.       86400   IN   NS   ns4.theszymek.ga.
    theszymek.ga.       86400   IN   NS   ns3.theszymek.ga.
    
    ;; ADDITIONAL SECTION:
    mail.theszymek.ga.   86400   IN   A   80.211.240.30
    ns3.theszymek.ga.   86400   IN   A   80.211.240.30
    ns4.theszymek.ga.   86400   IN   A   80.211.240.30
    
    ;; Query time: 349 msec
    ;; SERVER: 80.211.240.30#53(80.211.240.30)
    ;; WHEN: Thu Nov 22 09:00:54 +11 2018
    ;; MSG SIZE  rcvd: 146
     
    TheSzymek likes this.
  5. TheSzymek

    TheSzymek New Member

    I change NS to ns1 & ns2 and the problem has not been solved
     
  6. Your domain
    theszymek.ga
    is not well registered over the Internet
    Code:
    dig theszymek.ga
    
    ; <<>> DiG 9.11.3-1ubuntu1.3-Ubuntu <<>> theszymek.ga
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 33585
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 65494
    ;; QUESTION SECTION:
    ;theszymek.ga.           IN   A
    
    ;; Query time: 1341 msec
    ;; SERVER: 127.0.0.53#53(127.0.0.53)
    ;; WHEN: Thu Nov 22 11:52:13 +11 2018
    ;; MSG SIZE  rcvd: 41
    Code:
    whois theszymek.ga
      
       Domain name:
          THESZYMEK.GA
    
       Organisation:
          Gabon TLD B.V.
          My GA administrator
          P.O. Box 11774
          1001 GT  Amsterdam
          Netherlands
          Phone: +31 20 5315725
          Fax: +31 20 5315721
          E-mail: abuse: [email protected], copyright infringement: cop[email protected]
    
       Domain Nameservers:
          NS2.THESZYMEK.GA
          NS1.THESZYMEK.GA
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Maybe you have registered the domain using host names instead of IP-addresses? See chapter 1.7 in the DNS tutorial.
     
    TheSzymek and electronico_nc like this.
  8. Or you need to add Glue Record on your Registrar interface.
     
    TheSzymek likes this.
  9. TheSzymek

    TheSzymek New Member

    I created Glue Record's and i don't see effecets :/ I'm always see the default page od Apache.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    When you see the default page of apache and you're sure that it is the default page of your new server and not of any other server, then dns must be working. Did you add a website for that domain in ISPConfig and choose * in the IPv4 field as IP address?
     
    TheSzymek likes this.
  11. TheSzymek

    TheSzymek New Member

    Yes. I created website with domain "theszymek.GA" and chose * in the IP field.
     
    Last edited: Nov 25, 2018
  12. TheSzymek

    TheSzymek New Member

    I noticed that when I enable SSL for the domain theszyek and then enter the address in the browser bar by adding HTTPS, this domain works normally and points to the domain cure directory when I enter normally via HTTP it points to the default apache directory. In addition, if I remove the "GLUE RECORD" from the domain provider, the domain stops working completely.
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    This is no longer DNS problem. When you added the A-records for name servers, it was OK.
    I do not know how http goes to different website. But turn on redirect http to https in website settings.
    Have you done the usual browser cache clearing and using other browser?
     
    TheSzymek likes this.
  14. TheSzymek

    TheSzymek New Member

    Yes, I always clean the cache and use a few different browsers. I noticed that the problem only occurs with this site. In addition, when I turned on the redirect from HTTP to HTTPS, nothing happens, I do not redirect to the HTTPS address, while on another domain everything works fine, when I turned on the redirection also works. I added two times domain in ISPConfig and this not solve my problem.
     
    Last edited: Nov 25, 2018
  15. You seem to have done wrong things by your Registar:
    Code:
    whois theszymek.ga
    The domain you requested is not known in Freenoms database.
    Code:
    dig theszymek.ga
    
    ; <<>> DiG 9.11.3-1ubuntu1.3-Ubuntu <<>> theszymek.ga
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 10887
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 65494
    ;; QUESTION SECTION:
    ;theszymek.ga.           IN   A
    
    ;; Query time: 2078 msec
    ;; SERVER: 127.0.0.53#53(127.0.0.53)
    ;; WHEN: Mon Nov 26 08:31:34 +11 2018
    ;; MSG SIZE  rcvd: 41
     
    TheSzymek likes this.
  16. TheSzymek

    TheSzymek New Member

    Check now. I've added "glue records" from scratch
     
  17. Ghostdare

    Ghostdare Member

    Seems that your records are fine according to https://intodns.com/theszymek.ga

    Make sure that you request to VPS provider to change the PTR record according to your hostname.

    Also, browsing to your site ... i see a directory there "Portfolio"
     
    TheSzymek likes this.
  18. TheSzymek

    TheSzymek New Member


    I wrote to my VPS provider and I received instructions on how to set up reverse DNS. I will check the effects for 12h / 24h, etc.
    "Portfolio" is directory in apache2 web folder. Domain theszymek have a default website for ISPConfig.
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of the commands:

    hostname

    and

    hostname -f

    The server hostname has to be a subdomain that is neither used as website nor as email domain. In case you used theszymek.ga or www.theszymek.ga as hostname instead of a subdomain like server1.theszymek.ga which the install tutorial suggests, then you the see the apache default page instead of a website. To fix that you will have to set a correct hostname.
     
    TheSzymek likes this.
  20. TheSzymek

    TheSzymek New Member

    Thank you very much.
    My earlier hostname was "theszymek.ga". When I changed it to "host.theszymek.ga" everything works fine :)



    I only noticed such a small problem. When I have a Let's Encrypt certificate for one domain in ISPConfig, when I add HTTPS to another address from my ISPConfig, I am redirecting to the domain that has the ceftyfikat. Is it somehow set up or does it just have to be?

    Example:
    Two domains, theszymek.ga and theszymek.ml
    TheSzymek.ga has a certificate, theszyek.ml is gone.
    When I enter https to theszyek.ml it redirects me to theszyek.ga
     

Share This Page