DNS configuration not syncing

Discussion in 'Installation/Configuration' started by SwOsHiE, Nov 14, 2011.

  1. SwOsHiE

    SwOsHiE New Member

    Hello,

    Just installed a Mirror Setup with 2 servers under Debian 6.0.3. Everything is working, except that DNS 2 does not get it's configuration synced from DNS 1?

    With a DNS lookup I get "Lame server" on DNS2..

    Any advice?

    Best regards,
    Mattias
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. SwOsHiE

    SwOsHiE New Member

    Hello Till and thank you for the quick answer!

    Here is the debug output:


    14.11.2011-15:02 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    14.11.2011-15:02 - DEBUG - Found 2 changes, starting update process.
    14.11.2011-15:02 - DEBUG - Replicated from master: REPLACE INTO server (`server_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_name`,`mail_server`,`web_server`,`dns_server`,`file_server`,`db_server`,`vserver_server`,`proxy_server`,`firewall_server`,`config`,`updated`,`mirror_server_id`,`dbversion`,`active`) VALUES ('3','1','1','riud','riud','r','btsv03.burstbit.net','1','1','1','1','1','0','0','1','[global]\nwebserver=apache\nmailserver=postfix\ndnsserver=mydns\n\n[server]\nauto_network_configuration=\nip_address=192.168.10.3\nnetmask=255.255.255.0\ngateway=192.168.0.1\nhostname=btsv03.burstbit.net\nnameservers=192.168.0.1,192.168.0.2\nloglevel=0\nbackup_dir=/var/backup\nbackup_dir_ftpread=\n\n[mail]\nmodule=postfix_mysql\nmaildir_path=/var/vmail/[domain]/[localpart]\nhomedir_path=/var/vmail\npop3_imap_daemon=dovecot\nmail_filter_syntax=sieve\nmailuser_uid=5000\nmailuser_gid=5000\nmailuser_name=vmail\nmailuser_group=vmail\nrelayhost=\nrelayhost_user=\nrelayhost_password=\nmailbox_size_limit=0\nmessage_size_limit=0\n\n[getmail]\ngetmail_config_dir=/etc/getmail\n\n[web]\nserver_type=apache\nwebsite_basedir=/var/www\nwebsite_path=/var/www/clients/client[client_id]/web[website_id]\nwebsite_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/\nwebsite_symlinks_rel=n\nvhost_conf_dir=/etc/apache2/sites-available\nvhost_conf_enabled_dir=/etc/apache2/sites-enabled\nnginx_vhost_conf_dir=/etc/nginx/sites-available\nnginx_vhost_conf_enabled_dir=/etc/nginx/sites-enabled\nsecurity_level=20\nuser=www-data\ngroup=www-data\nnginx_user=www-data\nnginx_group=www-data\napps_vhost_port=8081\napps_vhost_ip=_default_\napps_vhost_servername=\nphp_open_basedir=[website_path]/web:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin\nhtaccess_allow_override=All\nawstats_conf_dir=/etc/awstats\nawstats_data_dir=/var/lib/awstats\nawstats_pl=/usr/lib/cgi-bin/awstats.pl\nawstats_buildstaticpages_pl=/usr/share/awstats/tools/awstats_buildstaticpages.pl\nphp_ini_path_apache=/etc/php5/apache2/php.ini\nphp_ini_path_cgi=/etc/php5/cgi/php.ini\ncheck_apache_config=y\nenable_sni=y\nnginx_cgi_socket=/var/run/fcgiwrap.socket\nphp_fpm_init_script=php5-fpm\nphp_fpm_ini_path=/etc/php5/fpm/php.ini\nphp_fpm_pool_dir=/etc/php5/fpm/pool.d\nphp_fpm_start_port=9010\nphp_fpm_socket_dir=/var/lib/php5-fpm\n\n[dns]\nbind_user=root\nbind_group=bind\nbind_zonefiles_dir=/etc/bind\nnamed_conf_path=/etc/bind/named.conf\nnamed_conf_local_path=/etc/bind/named.conf.local\n\n[fastcgi]\nfastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/\nfastcgi_starter_script=.php-fcgi-starter\nfastcgi_alias=/php/\nfastcgi_phpini_path=/etc/php5/cgi/\nfastcgi_children=8\nfastcgi_max_requests=5000\nfastcgi_bin=/usr/bin/php-cgi\nfastcgi_config_syntax=1\n\n[jailkit]\njailkit_chroot_home=/home/[username]\njailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh\njailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /usr/bin/lesspipe /usr/bin/basename /usr/bin/dirname /usr/bin/nano /usr/bin/pico\njailkit_chroot_cron_programs=/usr/bin/php /usr/bin/perl /usr/share/perl /usr/share/php\n\n[vlogger]\nconfig_dir=/etc\n\n[cron]\ninit_script=cron\ncrontab_dir=/etc/cron.d\nwget=/usr/bin/wget\n\n[rescue]\ntry_rescue=n\ndo_not_try_rescue_httpd=n\ndo_not_try_rescue_mysql=n\ndo_not_try_rescue_mail=n\n\n','89','1','26','1')
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'apps_vhost_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'network_settings_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Network configuration disabled in server settings.
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'postfix_server_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Processed datalog_id 91
    14.11.2011-15:02 - DEBUG - Replicated from master: REPLACE INTO server (`server_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_name`,`mail_server`,`web_server`,`dns_server`,`file_server`,`db_server`,`vserver_server`,`proxy_server`,`firewall_server`,`config`,`updated`,`mirror_server_id`,`dbversion`,`active`) VALUES ('3','1','1','riud','riud','r','btsv03.burstbit.net','1','1','1','1','1','0','0','1','[global]\nwebserver=apache\nmailserver=postfix\ndnsserver=mydns\n\n[server]\nauto_network_configuration=\nip_address=192.168.10.3\nnetmask=255.255.255.0\ngateway=192.168.0.1\nhostname=btsv03.burstbit.net\nnameservers=192.168.0.1,192.168.0.2\nloglevel=0\nbackup_dir=/var/backup\nbackup_dir_ftpread=\n\n[mail]\nmodule=postfix_mysql\nmaildir_path=/var/vmail/[domain]/[localpart]\nhomedir_path=/var/vmail\npop3_imap_daemon=dovecot\nmail_filter_syntax=sieve\nmailuser_uid=5000\nmailuser_gid=5000\nmailuser_name=vmail\nmailuser_group=vmail\nrelayhost=\nrelayhost_user=\nrelayhost_password=\nmailbox_size_limit=0\nmessage_size_limit=0\n\n[getmail]\ngetmail_config_dir=/etc/getmail\n\n[web]\nserver_type=apache\nwebsite_basedir=/var/www\nwebsite_path=/var/www/clients/client[client_id]/web[website_id]\nwebsite_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/\nwebsite_symlinks_rel=n\nvhost_conf_dir=/etc/apache2/sites-available\nvhost_conf_enabled_dir=/etc/apache2/sites-enabled\nnginx_vhost_conf_dir=/etc/nginx/sites-available\nnginx_vhost_conf_enabled_dir=/etc/nginx/sites-enabled\nsecurity_level=20\nuser=www-data\ngroup=www-data\nnginx_user=www-data\nnginx_group=www-data\napps_vhost_port=8081\napps_vhost_ip=_default_\napps_vhost_servername=\nphp_open_basedir=[website_path]/web:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin\nhtaccess_allow_override=All\nawstats_conf_dir=/etc/awstats\nawstats_data_dir=/var/lib/awstats\nawstats_pl=/usr/lib/cgi-bin/awstats.pl\nawstats_buildstaticpages_pl=/usr/share/awstats/tools/awstats_buildstaticpages.pl\nphp_ini_path_apache=/etc/php5/apache2/php.ini\nphp_ini_path_cgi=/etc/php5/cgi/php.ini\ncheck_apache_config=y\nenable_sni=y\nnginx_cgi_socket=/var/run/fcgiwrap.socket\nphp_fpm_init_script=php5-fpm\nphp_fpm_ini_path=/etc/php5/fpm/php.ini\nphp_fpm_pool_dir=/etc/php5/fpm/pool.d\nphp_fpm_start_port=9010\nphp_fpm_socket_dir=/var/lib/php5-fpm\n\n[dns]\nbind_user=root\nbind_group=bind\nbind_zonefiles_dir=/etc/bind\nnamed_conf_path=/etc/bind/named.conf\nnamed_conf_local_path=/etc/bind/named.conf.local\n\n[fastcgi]\nfastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/\nfastcgi_starter_script=.php-fcgi-starter\nfastcgi_alias=/php/\nfastcgi_phpini_path=/etc/php5/cgi/\nfastcgi_children=8\nfastcgi_max_requests=5000\nfastcgi_bin=/usr/bin/php-cgi\nfastcgi_config_syntax=1\n\n[jailkit]\njailkit_chroot_home=/home/[username]\njailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh\njailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /usr/bin/lesspipe /usr/bin/basename /usr/bin/dirname /usr/bin/nano /usr/bin/pico\njailkit_chroot_cron_programs=/usr/bin/php /usr/bin/perl /usr/share/perl /usr/share/php\n\n[vlogger]\nconfig_dir=/etc\n\n[cron]\ninit_script=cron\ncrontab_dir=/etc/cron.d\nwget=/usr/bin/wget\n\n[rescue]\ntry_rescue=n\ndo_not_try_rescue_httpd=n\ndo_not_try_rescue_mysql=n\ndo_not_try_rescue_mail=n\n\n','89','1','26','1')
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'apps_vhost_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'network_settings_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Network configuration disabled in server settings.
    14.11.2011-15:02 - DEBUG - Calling function 'update' from plugin 'postfix_server_plugin' raised by event 'server_update'.
    14.11.2011-15:02 - DEBUG - Processed datalog_id 93
    14.11.2011-15:02 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    14.11.2011-15:02 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
     
  4. SwOsHiE

    SwOsHiE New Member

    Maybe I should note that I have not done the MySQL Master-Master Replication yet nor the rsync for www and mailroot. But this should not affect the ispconfig replication for configuration files, right?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Correct. DNS sync will work without that.

    According to the output that you posted, the syncing is working fine.

    Please check with:

    nestat -tap

    if the dns server is running on the slave and check the syslog for bind / named errors.
     
  6. SwOsHiE

    SwOsHiE New Member

    I've tried the above but nothing works or show any errors. I looked up my network configuration and nothing is wrong there, the mysql tables is synced and ready (phpmyadmin) but the DNS lookup tool still says that my second DNS is LAME.

    Any thoughts ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the bidn config files to see if the domains have been wriiten on the secondary server in the same way they have been written on the primary.
     
  8. SwOsHiE

    SwOsHiE New Member

    I think every file in the /etc/bind/ folder is identical so no problem there, atleast the domain config files are identical. :confused:
     
  9. SwOsHiE

    SwOsHiE New Member

    Just found a possible problem, for some reason the network connection did not work in the right way, tried to restart the network service and ended up with lost connection (on remote site). Will try to fix it the next time I go there and see if the problem is resolved.

    Thanks for all the help, good for future troubleshooting!

    Best regards,
    Mattias
     

Share This Page