DNS Borked?

Discussion in 'Installation/Configuration' started by Ringo, Aug 26, 2005.

  1. Ringo

    Ringo New Member

    I installed ISPConfig today on my debian server and after the installation, I could no longer access my site via "www.xaix.com". For some reason the CNAME isn't working? I can access the same site if I type "ns.xaix.com". I was working fine but something has changed and I can't find where the change is. Im running debian sarge 3.1 and bind9. I've looked in the /root/ispconfig/isp/conf/ directory and in the files here and can't find what is missing or changed? Could use a little help on this one. Thanks in advance.

    Ringo
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What do you mean with that? Is www.xaix.com working, but you see the same page as when you type in ns.xaix.com in your browser?
    Or can't you connect at all with www.xaix.com?
    Which server is the DNS server for xaix.com? The machine where you installed ISPConfig?

    You could have a look at
    /etc/apache2/apache2.conf,
    /etc/apache2/vhosts/Vhosts_ispconfig.conf and the files in /etc/bind.
     
  3. Ringo

    Ringo New Member

    What I mean is if you type in www.xaix.com .. it can't be found anymore, however if you type in ns.xaix.com - my temp page will show. Meaning a possible change in DNS because www.xaix.com was being resolved befor the installation. So Im assuming that something has changed but Im not sure what. Yes this server is also running DNS/apache/ipconfig.
    I don't know if this might help or not but for some reason it didn't pick up my phpmyadmin or i should say it wont allow me to access it - however once again if I type in http://ns.xaix.com/phpmyadmin/ .. it shows. Most likely unrelated but ...
    I'll take a look at apache conf and see whats up. It's a new server Im just now setting up, but I desided to use apache 1.3.3. Don't have any vhosts on the system YET >......
    I've looked at etc/bind -- I made backups of all the files in that dir but theres no difference.
    There seems to be a file missing from /root/ispconfig/<something>/ bind stuff ... I dunno....
    Anyway thanks for a place to start looking :)
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There are no config files for your daemons under the /root/ispconfig/ tree. All the config files are in /etc/.

    Is your server authorative for your domains? Have you configured the primary records for your domains in ISPConfig DNS-Manager after you have installed ispconfig? ISPConfig deletes all existing BIND configuration on your server during install and you have to setup your DNS-Records in DNS-Manager again.
     
  5. Ringo

    Ringo New Member

    Man ...

    Wow you guys are the best - thanks for the quick replys.

    Yes my server is Authorative for all my domains. However I only have ONE domain atm - just my root domain which is xaix.com. I'd like to get this working correctly (or learn ispconfig better) before I actually transfer 100+ domains over hehe. Interesting comment about ISPConfig deleting my existing BIND config - are you saying it actually deletes all my /etc/bind/ * files?
    If thats what is suppose to happen .. it has not done so. I was reading that the Primary DNS entry is set to "default" but I have changed those to IP addys and removed the Default FQDN that was there. Am I misunderstanding the docs?

    Thanks

    P.S.
    It's really a very good app ... thanks for all the hard work...
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, it dont delete the /etc/bind/ * files, but it replaces your named.conf and your files in /etc/bind/ * are not included anymore.

    What do you mean with that? After you installed ISPConfig, the BIND Configuration is empty, there are no zones at all as default. Dont change any config files manually, use the web inteface or your changes will get lost!
     
  7. Ringo

    Ringo New Member

    No no my bind config is as it was -- the problem is I can't find where ISPConfig changed my CNAME from www to ns ? right now you can access my site by ns.xaix.com but NOT www.xaix.com. it wasn't like that before so something has changed but I can't find where -- I've looked at the ispconfig files under root -- but don't really know what file it's in or what i should change .. Im not very up on php coding. In the ISPConfig console the do I need to build that first DNS record? Do I need to build xaix.com even though it was built in bind before the installation?

    Thanks
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There are NO config files under /root/ispconfig for the daemons like bind, postfix and the main apache (See my post above).


    What result did you get when you run.

    Code:
    dig @localhost xaix.com
    If the server is not authoritive for that domain, you have to add the domain in ISPConfig.
     
  9. Ringo

    Ringo New Member

    info for dns

    Again what I'm trying to say is -- THIS SERVER WAS SOA before the installation process -- so .. If I have missed something in the admin docs please point me to it. If not how can I set my server back to SOA through the ISPConfig panel.

    Thanks
    Ringo
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, I have understand that and thats why i told you to setup the namserver settings again in the ISPConfig controlpanel.

    Mybe you've missed the part where the install documentation and the installer told you that some of your current installation will be overwritten and thats why you have to enter them again in the controlpanel.

    1) You entered ns.xaix.com in the field "Domain (SOA):" of your primary DNS record in the DNS manager, it must be "xaix.com" because the autority starts at xaix.com (SOA maens Start Of Autority).
    2) Go to the "records" tab of the xaix.com DNS records and add a new A-Record with the field Hostname set to "ns" and the IP address pointing to your server.

    IT is still SOA, but not
     
  11. Ringo

    Ringo New Member

    Well no I didn't miss it but - read below.


    Right that is what I first did incorrectly - I changed it and it still stayed the same - I can't seem to add a CNAME for www to ns because it says that record is already in there.

    Heres my setup now as it stands.
    [​IMG]
    [​IMG]
    [​IMG]

    I really can't see anything wrong with it -- so your gonna have to point it out to me. Again I can't add a CNAME for www -- ipsconfig says theres already an entry for it.

    Thanks
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I suppose you added an www c-name record earlier and deleted it? Empty the recycle bin to delete it from the database. Then add an www as A-record.
     

Share This Page