DNS blues with Network Solutions

Discussion in 'HOWTO-Related Questions' started by Jaded1, May 5, 2007.

  1. Jaded1

    Jaded1 New Member

    First of all I would like to give props to Falko, Till and all others for all their hard work helping others get the perfect setup, providing excellent tutorials and follow-ups on the forum.

    I followed these tutorials to the "T" and am on the verge of having an awesome server.

    I do have one final problem that I hope you may help me with. It is concerning DNS. I have researched the forums and googled till I am blue in the face but can't seem to understand what I am doing wrong.

    Background: I have the following on and ASSL line assigned by my ISP

    WAN IP 203.152.62.26 subnet 255.255.255.252

    Lan IP range 203.121.171.192 - 203.121.171.199

    Gateway 203.121.171.193

    203.121.171.194 Static IP address
    203.121.171.195 Static IP address
    203.121.171.196 Static IP address
    203.121.171.197 Static IP address
    203.121.171.198 Static IP address
    203.121.171.199 Cannot use (told that it was used for broadcast)

    I also have eight domains registered with Network Solutions, previously I used only four of them on four of the addresses above with ISPCONFIG and this worked because it was IP-based.
    EX:
    203.121.171.194 fabledglory.com
    203.121.171.195 merdance.com
    203.121.171.196 jadedreality.net
    203.121.171.197 transtropics.com


    My ultimate goal is to serve all eight domains on one or more of the addresses above. I am under the understading that ISPCONFIG allows you to serve multiple web sites on the same IP so I went to the DNS control panel of Network Solutions and tried to share merdance .com with jadedreality.net just to see if this will work.

    Dartan.jadedreality.net was the name I replaced server.example.com in the perfect setup routine so I pointed both domain names to go to there and to go to the IP address of 203.121.171.196.

    Then I went into ISPCONFIG and set up dartan.jadedreality.net (SOA) as the master dns server with 203.121.171.196 as the IP address. I setup merdance.com as a slave domain.

    I then setup several sites: www.jadedreality.net, webmail.jadedreality.net, www.merdance.com and webmail.merdance.com. All of using IP 203.121.171.196. It made the appropriate files in var/www. If I sit at the console of this server everything seems to work fine when I check each site with a browser. But....if I go to another computer (203.121.171.194) I can only see the jadedreality sites. I allowed almost 36 hours for the changes in Network Solutions to be propigated but I just feel like something isn't right.

    Can you tell me if I am going in the right direction??? Is my train of thought correct in this setup....will I be able to share all of these websites on the single Ip of 203.121.171.196 using ISPCONFIG??? Anything that I should have done different???

    Any help you can provide will be greatly appreciated.
     
  2. Jaded1

    Jaded1 New Member

    I followed the How to with Godaddy and Ispconfig, some of the steps were quite different but I think things are set. I also get the answer when I dig ns1.jadedreality.net so I assume that everything has been propagated.

    When I go to dnsreport.com I get the following errors for jadedreality.net:

    ERROR: You have one or more lame nameservers. These are nameservers that do NOT answer authoritatively for your domain. This is bad; for example, these nameservers may never get updated. The following nameservers are lame:
    203.121.171.196
    203.121.171.195

    ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are:
    ns1.jadedreality.net.
    ns2.jadedreality.net.

    No valid SOA record came back:
    is not jadedreality.net.

    Can anyone tell me how to fix these??

    I also cannot access any of my sites through a browser and I cannot access ispconfig admin unless I use the IP address.
     
  3. falko

    falko Super Moderator

  4. Jaded1

    Jaded1 New Member

    The Go daddy tutorial was a mistake for me.....I really don't need to host my own dns servers.......besides dns is confusing enough without trying to figure out glue records.

    I am going to go to the way you mentioned here
    http://www.howtoforge.com/forums/showpost.php?p=6292&postcount=4

    I went to the registrar's dns control panel set up a "technical domain" one that I will not serve pages or email on, used their dns servers and pointed it to my static IP address. I made four entries as A records....
    @none jadedreality.net, ns1.jadedreality.net, ns2.jadedreality.net and dartan.jadedreality.net

    I guess once these are propagated, I can use any of them in my server and dns-manager settings in ispconfig. ( Similar to you using ns1-ns6.hostmu.com)

    I also assume that once this is done I can setup as many domains as I want by using the above A records as ispconfig nameserver entries. ( Then move them in my registra's dns control panel)

    And I assume that as I enter these new domains into ispconfig that all of them can share the same IP.

    Can you tell me if I am right about this?????
     
    Last edited: May 6, 2007
  5. falko

    falko Super Moderator

    That's right.

    Correct, too.
     
  6. Jaded1

    Jaded1 New Member

    Yessssssssss................... that is the way to do it. Just didn't understand the technical domain. Its seems that ns1.jadedreality.net would be able to resolve www.jadedreality.net. But I guess that may be an issue of what is requested first. I do have my original webmail.jadedreality.net site still loaded and its working. I wonder why it can resolve webmail but not www. You know the old saying if it isn't broke don't fix it.
    I'll leave it as long as its working.

    Anyway all sites are working and now I have the perfect server. The sky is the limit.


    You guys are the bomb. Thanks again.
     

Share This Page