DNS and Postfix issues

Discussion in 'Installation/Configuration' started by issya, Apr 17, 2007.

  1. issya

    issya New Member

    Hello, I am trying to setup an e-mail with ISPConfig. All seemed to be working until I say my deferred e-mail for Postfix. I am getting the below error message in my mail.log. Mucho thanks for any help.

    Apr 17 12:12:34 www postfix/qmgr[23125]: 22924411365: to=<[email protected]>, relay=none, delay=66558, delays=66482/76/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=juno.com type=MX: Host not found, try again)

    I used the HOWTO for the perfect server setup on Ubuntu 6.10. Below are some config files for Ubuntu.

    I own the domain www.builderbulletins.com. I made the hostname for my Ubuntu box www.builderbulletins.com. I made my MX record www.builderbulletins.com.

    My HOSTS file is

    127.0.0.1 localhost.localdomain localhost
    192.168.2.1 www.builderbulletins.com www

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts


    My resolv.conf is (Which are my ISP's name servers)

    nameserver 216.199.XXX
    nameserver 216.199.XXX.XXX

    Here is my nsswitch.conf

    passwd: compat
    group: compat
    shadow: compat

    hosts: files dns
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis


    Here is my main.cf (at least the part that matters)


    myhostname = www.builderbulletins.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = builderbulletins.com
    #mydestination = $myhostname, localhost.$mydomain, localhost
    relayhost =
    mynetworks = 127.0.0.0/8 192.168.2.0/24
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names






    Dig works about half the time also.

    Here is my digg A output

    ; <<>> DiG 9.3.2 <<>> A builderbulletins.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32659
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;builderbulletins.com. IN A

    ;; ANSWER SECTION:
    builderbulletins.com. 2401 IN A 216.199.187.234

    ;; AUTHORITY SECTION:
    builderbulletins.com. 512 IN NS PARK15.SECURESERVER.NET.
    builderbulletins.com. 512 IN NS PARK16.SECURESERVER.NET.

    ;; ADDITIONAL SECTION:
    PARK15.SECURESERVER.NET. 229 IN A 64.202.165.118
    PARK16.SECURESERVER.NET. 229 IN A 208.109.80.43

    ;; Query time: 75 msec
    ;; SERVER: 216.199.XXX.XXX#53(216.199.XXX.XXX)
    ;; WHEN: Tue Apr 17 12:17:24 2007
    ;; MSG SIZE rcvd: 144


    Here is my dig MX output (well it is not working atm)
    DNSStuff.com says...

    builderbulletins.com. MX IN 3600 www.builderbulletins.com. [Preference = 10]
     
  2. Hans

    Hans Moderator ISPConfig Developer

    I would try this:

    Change myorigin= builderbulletins.com within myorigin = /etc/mailname

    The file /etc/mailname should contain your fqdn like host.builderbulletins.com

    If the output of hostname -f is server1.builderbulletins.com put server1 as the host.

    Change smtpd_sasl_local_domain = within smtpd_sasl_local_domain = $myhostname

    What is your output of hostname -f anyway?
     
    Last edited: Apr 17, 2007
  3. issya

    issya New Member

    Thanks

    Thanks for the reply. My host is www. I made the suggested changes and rebooted and it is still giving the same error message.

    hostname -f is www.builderbulletins.com. Is this wrong?
     
  4. Hans

    Hans Moderator ISPConfig Developer

    www should be the name of your physical machine (your server).
    What is within your file /etc/hosts ?
     
  5. issya

    issya New Member

    Name

    That is what I named it. Below is my /etc/hosts.

    127.0.0.1 localhost.localdomain localhost
    192.168.2.1 www.builderbulletins.com www
     
  6. Hans

    Hans Moderator ISPConfig Developer

    In principle you did it right, but i would prefer a different name for your host then www, for instance server1.

    Is the output of the command: hostname the same as for the command hostname-f ?

    Do you see any errors whitin your mail log files?
     
  7. issya

    issya New Member

    Hostname

    Hostname and hostname -f produce the same output. I can change it to server1 but would that mean my MX records change also? The error I have been getting on every e-mail sent has been....


    Apr 17 12:12:34 www postfix/qmgr[23125]: 22924411365: to=<[email protected]>, relay=none, delay=66558, delays=66482/76/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=juno.com type=MX: Host not found, try again)
     
  8. Hans

    Hans Moderator ISPConfig Developer

    This looks as if your system cannot resolve domains. What is within /etc/resolv.conf? Are there any DNS servers in it?
     
  9. issya

    issya New Member

    Nameservers

    My resolv.conf is (Which are my ISP's name servers)

    nameserver 216.199.XXX
    nameserver 216.199.XXX.XXX
     
  10. issya

    issya New Member

    Solved

    Thank you for all of the great help. I ended up naming the box server1.builderbulletin.com and changed it all in the corresponding Postfix config files. I also put my nameserver to 127.0.0.1 in Resolv.conf and the resolved all of the DNS. I would assume because of bind.

    Thanks again, I am glad there are people here to help.
     

Share This Page