DNS and E-mail setup, multiple domains help!

Discussion in 'Installation/Configuration' started by mnewbegin, Nov 14, 2007.

  1. mnewbegin

    mnewbegin New Member

    I have added a few domains to my ISPConfig setup, but it seems as if they are reachable in house but not with the "www" prefix infront of them.

    also, is this pri.0.168.192.in-addr.arpa correct, I guess this was auto generated from ISPConfig, which is a godsend but should I be using that local ip address in that record?

    $TTL 86400
    @ IN SOA hostmaster. (
    2007111304 ; serial, todays date + todays serial #
    28800 ; Refresh
    7200 ; Retry
    604800 ; Expire
    86400) ; Minimum TTL
    129 PTR lyncomail.com.
    129 PTR www.lyncomail.com.
    129 PTR mac-lin.com.
    129 PTR www.mac-lin.com.
    129 PTR maclinmedical.com.
    129 PTR www.maclinmedical.com.


    When I add a domain in ispconfig, it automatically uses my local ip address.

    A Record
    IP-Adresse Hostname www

    also it shows underneath mailserver

    Mailserver Hostname

    because when I was setting up it wouldnt take the domain as one it could find so i read to use www for hostname and my ip address for the domain name.

    How do i fix this????

    And what do i use to configure my 50+ email addresses I need to setup still?

    Any help would be appreciated.
  2. lubos

    lubos New Member

    Hi mnewbegin

    1. When did you input www and IP address? Was it when you installed ISPConfig or when you installed server (OS)?
    If it was when you installed ISPConfig - to fix your domain go to => Management => Server => Settings => and change your domain name and IP address if needed. I ma afraid that you will have to fix your websites settings afterwards.

    2. About pri.0.168.192.in-addr.arpa:
    do you want to run your own DNS server? In this case look here and here for more info. Basicaly you will need to change your internal IP to external IP for DNS settings. (do not mix it with website settings - see bellow!)

    And 3.
    If you want your websites to be accessible, they have to use internal IP addresses in ISP manager => New website menu. If you use external IP for them, your visitors will land on Shared page warning asking them to insert name and not IP address even if they used name.

    I am newbie too but this I already discovered. Hope it will help. ;)
  3. mnewbegin

    mnewbegin New Member

    thanks for the response.

    I put in

    the www and ip address when i installed ispconfig.
    Afterwards the following information has to be provided:

    Please enter your MySQL server: E.G. localhost
    Please enter your MySQL user: E.G. root
    Please enter your MySQL password: Your MySQL password
    Please enter a name for the ISPConfig database: E.g. ispconfigdb
    Please enter the IP address of the ISPConfig web: E.g.
    Please enter the host name: E.g. www
    Please enter the domain: E.g. xyz.de (((Here I put in my local IP)))
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: If you want to use your control panel with SSL, select 1. You can then access it under https://www.xyz.de:81. If you want to access it under http://www.xyz.de:81, choose 2.
  4. lubos

    lubos New Member

    Hi mnewbegin

    did you tried to fix your ip in => Management => etc. as I stated before ?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you want to use the IP during setup instead of a domain, you will have to leave hostname empty in the installer.
  6. mnewbegin

    mnewbegin New Member


    can i change it now and have it work?

    i just want to make sure its accessible by the www prefix and just with the plain http://
  7. lubos

    lubos New Member


    After few PM we connected together and mnewbegin's ISPConfig is now up and running :)
    Last edited: Dec 10, 2007

Share This Page