DNS and DMZ

Discussion in 'Installation/Configuration' started by fycserv, Oct 25, 2007.

  1. fycserv

    fycserv New Member

    I work very happy with ISPConfig when the server that holds the application (ISPConfig) is attached directly to the cable. I just gave the static address to the server, run the perfect setup with godaddy and everything worked perfect.

    Now I have a router between the cable and my server so i used a DMZ. I have been really confused about what address should I select for my sites. should I used the local ip address or the static ip address.

    When I select the local Ip address as a shared Ip for my sites, I did a ping and the system came up with something like pinging 190.168.1.10, for me totally unacapteble as this address is a LAN address...but, it was configured like that. Then I changed the setup of my sites to the static address and the ping gave me, as expected, the Shared static address, but i can't still see the wellcome page when i write www.one_of_my_domains.com in a browser.

    Please, help with this...


    By the way, congratullations for such a good tool.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You ust use the internal IP address for the websites and the external IP address for DNS-Records in the dns manager.
     
  3. fycserv

    fycserv New Member

    What about the emails with DMZ

    Till,

    I really appreciate your help, I followed you and now I'm able to see the wellcome pages of my sites.

    The only one thing that still does not work is the emails. The only one difference between my old system and my new system in that matter is that selected https instead http during installation,

    Of course, before I posted this question i did some test from other emails accounts and this is what the system returned:

    Reporting-MTA: dns; Gymserver
    X-Postfix-Queue-ID: D49F35158DB
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Thu, 25 Oct 2007 09:24:37 -0500 (COT)

    Final-Recipient: rfc822; [email protected]ldomain
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.4.4
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=Gymserver.localdomain type=A: Host not found

    Thanks in advance.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that the variables mydomain and myhostname in /etc/main.cf contain a valid hostname that points to your server.
     
  5. fycserv

    fycserv New Member

    Something that has to be with godaddy

    Hi Till,

    Still here with problems. I could not find the /etc/main.cf file on my linux fedora tree. But I manage to change the names as you suggested and now, when someone trys to get some of my emails account, this is the message they always get:

    ____________

    <[email protected]> (expanded from <[email protected]>): host
    smtp.secureserver.net[64.202.166.12] said: 553 sorry, relaying denied from
    your location [190.84.233.181] (#5.7.1) (in reply to RCPT TO command)
    Reporting-MTA: dns; fycserver.com
    X-Postfix-Queue-ID: 24F1E5158A5
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Fri, 26 Oct 2007 16:17:27 -0500 (COT)

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.0.0
    Remote-MTA: dns; smtp.secureserver.net
    Diagnostic-Code: smtp; 553 sorry, relaying denied from your location
    [190.84.233.181] (#5.7.1)

    _________

    I followed the instructions given By Falko in his "creating your own DNS with ISPConfig and Godaddy", and for one year as I told you once...everything worked perfect, so that's why the following support by godaddy staff pushed me to call them:

    ________

    Support Staff Response
    Dear Fernando Yepes,

    Thank you for contacting Online Support. Please ensure that port 25 is open on any software or hardware firewalls you may be running. Should this be the case, your Internet Service Provider (ISP) may be practicing "anti-relaying", which is when an ISP prohibits the use of third-party SMTP (outgoing mail) servers on their network. Please contact your ISP to determine if this is the case. If so, you should be able to simply use their SMTP server with your domain E-Mail account. They'll be able to provide the appropriate settings for this.

    Please let us know if we can assist you in any other way.

    ________


    Does the DMZ produces all this problems with ISPConfig, I feel more confident of ISPconfig than in my knowledge.

    Thank you very much.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The correct location of the file is /etc/postfix/main.cf.
     
  7. fycserv

    fycserv New Member

    Solved

    Thank you very much.

    I just changed the MX records in my godaddy account and 8 hours after it, everything started working as usual.

    I'm really shamed beacuse later, i found in this forum, many direct and indirect references to the problem that suggest the solution. I guess the forum is getting to big so surfing trought the whole content is almost impossible. It must be really hard for you to write several times about the same problem.

    The problem I had was due to my lazyness that made me follow the directives given by Falko in his "how to do your own DNS with ISPConfig and Godaddy" It must be obvious for you that the MX records must point to our mail machinne, but as I was just following the instructions I didn't even think about this little detail. If there exists any way to add this fact to that excellent article (Falko's one), let me know, I'll be really glad to do so, in this way, you wont receive questions about this problem anymore.

    Thankfully,

    Fernando
     

Share This Page