DKIM on ISPConfig3 Server Question

Discussion in 'HOWTO-Related Questions' started by giganet, Aug 10, 2009.

  1. giganet

    giganet New Member

    Hello group...

    I am presently working on: Quick And Easy Setup For DomainKeys Using Ubuntu, Postfix And Dkim-Filter

    This server is running Ubuntu 9.04 and ISPConfig3...

    The server will not authenticate using DKIM, I have tried emailing to a Yahoo account and using the DKIM tool located at

    When I run 'tail -f /var/log/mail.err' I receive the following:
    Aug 10 20:16:13 giganetwireless dkim-filter[12139]: 2EE11B8C003: no signature data
    Aug 10 20:16:13 giganetwireless dkim-filter[12139]: D45E6B8C19A: no signature data
    Aug 10 20:16:28 giganetwireless dkim-filter[12139]: 6DF32B8C003: no signature data
    Aug 10 20:16:29 giganetwireless dkim-filter[12139]: 7A8ABB8C19A: no signature data
    Aug 10 20:17:06 giganetwireless dkim-filter[12139]: D5A26B8C003: no signature data
    Aug 10 20:17:07 giganetwireless dkim-filter[12139]: 61E55B8C19A: no signature data
    Aug 10 20:23:32 giganetwireless dkim-filter[12139]: D1864B8C003: no signature data
    Aug 10 20:23:33 giganetwireless dkim-filter[12139]: 1A498B8C19A: no signature data
    Aug 10 20:24:35 giganetwireless dkim-filter[12139]: 6C810B8C003: no signature data
    Aug 10 20:24:36 giganetwireless dkim-filter[12139]: 25BEFB8C19A: no signature data
    Likewise when I try to run '/etc/init.d/dkim-filter restart' I receive:
    Starting for DKIM verification only
    dkim-filter: /etc/dkim-filter.conf: configuration error at line 22: unrecognized parameter

    Below are the contents of '/etc/dkim-filter.conf'
    # Log to syslog
    Syslog                  yes
    # Required to use local socket with MTAs that access the socket as a non-
    # privileged user (e.g. Postfix)
    # UMask                 002
    # Sign for with key in /etc/mail/dkim.key using
    # selector '2007' (e.g.
    KeyFile         /var/gnw-dkim-filter/private.key
    Selector                mail
    #Selector                2007
    # Common settings. See dkim-filter.conf(5) for more information.
    AutoRestart             no
    Background              yes
    Canonicalization        simple
    DNSTimeout              5
    Mode                    sv
    SignatureAlgorithm      rsa-sha256
    SubDomains              no
    UseSSPDeny              no
    ASPDiscard              no
    Version         rfc4871

    Following are the lines added to the base of '/etc/postfix/'
    milter_default_action = accept
    milter_protocol = 2
    smtpd_milters = inet:localhost:8891
    non_smtpd_milters = inet:localhost:8891

    When I view full header information of email received at Yahoo it appears as follows:
    Authentication-Results:; domainkeys=neutral (no sig);; dkim=neutral (no  sig)

    In ISPConfig3 Firewall I have opened port 8891 TCP & UDP too.

    What would be the best means of troubleshooting DKIM functionality?

    Thanking you in advance for your help.

    Best Regards
    Last edited: Aug 11, 2009

Share This Page