Dkim not work with Rspamd

Discussion in 'ISPConfig 3 Priority Support' started by andreasli, Mar 1, 2021.

  1. andreasli

    andreasli New Member HowtoForge Supporter

    Hi

    I use Debian 10 with Rspamd. This morning when i tested one of my domain with mail-tester.com and glockapps i notised that dkim is not working. My first thought was that it was only one domain name, but when i tested dkim with other domains on my mail server, i realized that it affect all domains on my mail server.

    I have tried to generate a new dkim key for one of my domains, but it seems to have no effect. What can i do for finding the problem?
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    What exactly is not working? Can you share the full test result?

    Make sure the DKIM checkbox is checked in the mail domain settings.
     
  3. andreasli

    andreasli New Member HowtoForge Supporter

    Hi
    The problem is that my dkim keys is not accepted. The dkim certs and dns records is generated, but the test result shows that is not valid. I know that it has worked before, but i can´t say for how long times this problem has existed.
    You can se my results for mail-tester.com by clicking on this link.
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    It shows me that your DKIM signature is valid.

    Perhaps the DNS record change wasn't propagated, but it is now?
     
  5. andreasli

    andreasli New Member HowtoForge Supporter

    It still shows 9.9/10 and it should be 10/10 if everything is okay.

    The strange thing is that if i check the report for mail-tester.com under "You're properly authenticated" it shows that dkim is valid. But under "SpamAssassin thinks you can improve" it shows that dkim is not valid. It can be a false-possitive, but i know that i had 10/10 20 days ago.

    I will wait until tomorrow att see if it still shows the same result.
     
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Try sending a new test mail to that service now, I suspect it will work.
     
  7. andreasli

    andreasli New Member HowtoForge Supporter

    I made a new test from two different domains, but it still shows 9.9/10.
     
    Last edited: Mar 1, 2021
  8. andreasli

    andreasli New Member HowtoForge Supporter

    I made a test with app.mailgenius.com instead of mail-test.com and it shows that dkim is valid. I also made a new test with app.glockapps.com and no mails was marked as spam, so it seems to work now.

    Thank you @Th0m for the help :)
     
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Glad to hear, no problem.
     

Share This Page