DKIM Not Signing Email in localhost

Discussion in 'Installation/Configuration' started by Slayer, Jun 24, 2020.

  1. Slayer

    Slayer New Member

    Hellow,

    I reinstalled my server with Debian 10 using the Perfect Server tutorial excluding the installation of clamav and disabled it in amavis with "@bypass_virus_checks_maps = (1);", everythink its ok.

    When I send mail by the SMTP (installed Mautic or external software), DKIM is signing, but using php, sendmail or mutt, DKIM not signing email. I checked amavis and postfix configs and logs and dont found the problem.

    Anyone can help?

    Thanks!
     
  2. Th0m

    Th0m Active Member HowtoForge Supporter

    This is because it doesn't authenticate through your SMTP daemon. You can setup a relay for sendmail to send through the server with a valid account, and you can do the same with PHP scripts.
     
  3. Jesse Norell

    Jesse Norell Well-Known Member

    Yeah, if you can send via smtp, it's setup to sign. Signing of mail from sendmail (rather, passing through the pickup(8postfix) daemon) should be possible - I thought as simple as changing the default content_filter to port 10026 for virtual mailboxes, but that didn't work, so still needs a bit more research. Right now the default content_filter is for port 10024 (no signing).

    If you're up for it, try switching to rspamd, it might work there (I haven't tried it yet, but it doesn't use a content_filter at all, so stands a chance of working).
     
  4. Slayer

    Slayer New Member

    The server running Debian 10 is in production, Im thinking switch to rspamd.

    I have the backup server that was running Debian 9 and DKIM worked on the installed websites and root scripts, I compared /etc/postfix/, /etc/amavis/ config files, but nothing different.
     

Share This Page