DKIM not signing "cannot stat key file:Permission denied"

Discussion in 'General' started by hebbet, Aug 12, 2020.

  1. hebbet

    hebbet New Member

    i already checked the similar topics and tried the suggestions.
    2020-08-12 14:43:06 #2051(normal) <6858a2>; dkim_signing; dkim_signing.lua:125: using key "/var/lib/amavis/dkim/", use selector "default" for domain ""
    2020-08-12 14:43:06 #2051(normal) <6858a2>; task; dkim_module_load_key_format: cannot load dkim key /var/lib/amavis/dkim/ cannot stat key file: '/var/lib/amavis/dkim/' Permission denied
    the folder /var/lib/amavis/dkim/ is owned by amavis, "groups _rspamd" returns _rspamd : _rspamd amavis

    i tried switching back to amavis and back to rspamd, i restarted rspamd etc.
    i also tried reconfiguring the services.

    it is ubuntu 20.04.1 with the git stable-3.1 branch
  2. hebbet

    hebbet New Member

    after comparing the chmod of the folders with an ubuntu 18.04 server i noticed a difference:
    on 20.04 the folder /var/lib/amavis/dkim had 700, on ubuntu 18.04 750

    after changing it to 750 it works.

Share This Page