DKIM is not generated

Discussion in 'Installation/Configuration' started by lweb20, Jun 17, 2018.

  1. lweb20

    lweb20 New Member

    A few days ago I did a clean installation of IspConfig and I had a problem. To create a mail domain does not work correctly generating dkim private key.

    Before, the text "default" appeared but now even when adding it manually it is deleted when the generate button is pressed. I do not know what it could be.

    My environment is ISPConfig 3.1.12 on Ubuntu 18.04.

    Please help.


    Sorry for my bad english :oops:
  2. lweb20

    lweb20 New Member

    Any ideas?
  3. recin

    recin Member

    What did the log sais?
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    There is a bug in 3.1.12, updae to git-stable.
    lweb20 likes this.
  5. lweb20

    lweb20 New Member

    Thanks, but how?. I did the installation from the download section of the web.
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. Zague

    Zague New Member

    Hello Guys I am using ISPConfig 3.1.13 in CentOS 7 and the GUI is not creating the key entries in /etc/amavisd/60-dkim, I have tried re generate the dkim record, deactive and active, but nothing.
    I can add it manually but I would like to know if this can be fixed.
    The keys are created correctly (see picture) but the entries in entries in /etc/amavisd/60-dkim are not completed
    Some point in time this worked but today does not work anymore
    Any Idea?

    Attached Files:

  8. Zague

    Zague New Member

    The issue was fixed the GUI is creating the file in /etc/60-dkim instead /etc/amavisd/60-dkim, a link of file solve this problem

Share This Page