DKIM - how to publish the public key...

Discussion in 'ISPConfig 3 Priority Support' started by DrMartinus, Oct 14, 2018.

  1. DrMartinus

    DrMartinus Member HowtoForge Supporter

    Hi,
    one more thing is there. As gogle seems that all mails from my domain are Spam, I'd like to add the DKIM service. I tried it, but then no mails reach their destination. So I disabled it again. I searched the forum and other places and found that there is no public key available:
    Code:
     default._domainkey.mydomain => invalid (public key: not available)
    I know that the public key must be handed over to the DNS, but I have none (DNS) on my server, and I can't access (at least not to my knowledge) the domain server of my provider. I guess there are ways to do that, but I need once again a little help from my friends... ;)

    Unfortunately, even though I disabled DKIM, still mails aren't sent away. I have the following log entry:
    Code:
    Oct 14 15:58:20 mydomain postfix/smtpd[13277]: connect from xxxxxxx.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]
    Oct 14 15:58:20 mydomain postfix/smtpd[13277]: NOQUEUE: filter: RCPT from xxxxxxx.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<[xxx.xxx.xxx.xxx]>
    Oct 14 15:58:20 mydomain postfix/smtpd[13277]: 5A9A94F8987: client=xxxxxxx.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx], sasl_method=PLAIN, [email protected]
    Oct 14 15:58:20 mydomain postfix/cleanup[13282]: 5A9A94F8987: message-id=<[email protected]>
    Oct 14 15:58:20 mydomain postfix/qmgr[13156]: 5A9A94F8987: from=<[email protected]>, size=4492, nrcpt=1 (queue active)
    Oct 14 15:58:20 mydomain postfix/smtp[13159]: connect to 127.0.0.1[127.0.0.1]:10026: Connection refused
    Oct 14 15:58:20 mydomain postfix/smtp[13159]: 5A9A94F8987: to=<[email protected]>, relay=none, delay=0.12, delays=0.12/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10026: Connection refused)
    Oct 14 15:58:21 mydomain postfix/smtpd[13277]: disconnect from xxxxxxx.dip0.t-ipconnect.de[xxx.xxx.xxx.xxx]
    To be precise: In the client, it says the mail has been sent successfully. But the receiver never receives the mail.
     
    Last edited: Oct 14, 2018
  2. DrMartinus

    DrMartinus Member HowtoForge Supporter

    I discovered last night that, even though I disabled DKIM in the UI, all the related lines in amavisd.conf were still active. After commenting them out, E-Mail receiving and sending worked again. I consider this a bug...
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to add the dkim key at your provider when you don't run your own name server. Ask the support of your provider on how to add DNS records to his system and then get the key from mail domain settings in ISPConfig and add it at your provider.

    I'll try if I can reproduce that here.
     

Share This Page