Dist upgrade from Ubuntu 12.04 to 14.04 is it ok?

Discussion in 'Installation/Configuration' started by RobMorin, Apr 30, 2014.

  1. RobMorin

    RobMorin New Member

    Hello all...

    I was wondering i have Ubuntu 12.04 with ISPconfig 3.0.5.3
    I would like to simply do a "do release upgrade"

    Anyone see any caveats? One main reason is that we have a few clients wanting PHP 5.4

    Thanks..
     
  2. ChrazzyChris

    ChrazzyChris New Member

    Dont do it

    I just stoopidly ran a dist-upgrade on my server, and now it's borked completely.

    Looks like FCGIWrapper is foobar'd and I don't know enough to get it working again.

    Now I can still FTP into all the accounts on the server, and I am hoping that MySQL is still all ok, it's just apache2 that seems to be a huge mess, so if anyone would like to help me fix it I would really appreciate it, and we can post the fix in case anyone else runs into the same issue.

    I am so gutted, the server was working perfectly for months and months, I always keep it up to date, just today I did the update, as I always do, and this time, bang! No more.

    I don't really want to have to reinstall the whole server just to get it back to a working server again, as I have too much data on there I don't want to lose so please someone help. :'(

    Thanks

    Christian.
     
  3. frprim

    frprim New Member

    Last edited: May 1, 2014
  4. RobMorin

    RobMorin New Member

    Thanks for the reply Chris... I will be very careful then and read that post... sorry to hear about your issues... I am sure you can fix it, just need to go one step at a time and have patients...

    Start to post some errors or log files and descriptions of one problem and lets go from there...

    Good luck buddy!
     
  5. RobMorin

    RobMorin New Member

  6. ChrazzyChris

    ChrazzyChris New Member

    OK so I've gone through some of the examples...

    I don't think i'm anywhere better off, perhaps a little worse off, feel like I have just borked my server completely. :'(

    So I start at ..

    Step 14: Install Apache2, PHP5, phpMyAdmin, FCGI, suExec, Pear, And mcrypt

    Because the server is working, I can already SSH in and the steps before seem to check out.

    The results for step 14 are:

    Code:
    [email protected]:/etc/apache2/sites-enabled# apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-curl php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp libruby libapache2-mod-ruby libapache2-mod-python libapache2-mod-perl2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libruby is already the newest version.
    mcrypt is already the newest version.
    php-auth is already the newest version.
    phpmyadmin is already the newest version.
    imagemagick is already the newest version.
    libexpat1 is already the newest version.
    ssl-cert is already the newest version.
    apache2 is already the newest version.
    apache2-doc is already the newest version.
    php5 is already the newest version.
    php5-cgi is already the newest version.
    php5-cli is already the newest version.
    php5-gd is already the newest version.
    php5-mysql is already the newest version.
    libapache2-mod-php5 is already the newest version.
    php-pear is already the newest version.
    php5-common is already the newest version.
    php5-curl is already the newest version.
    php5-imap is already the newest version.
    php5-mcrypt is already the newest version.
    php5-imagick is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed
     apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed
     apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed
     apache2-suexec : Depends: apache2-suexec-pristine (= 2.4.9-1+deb.sury.org~precise+1) but it is not going to be installed
     apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    
    This is as far as I want to go on my own now, as I really don't want to mess it up further.

    I have managed to get a full dump of my sql database including all users etc, just in case this can all be sorted and got back to a working ISPConfig setup with the current sites etc.

    Thanks guys for helping me out.
     
  7. ChrazzyChris

    ChrazzyChris New Member

    By the way, it's still on 12.04 LTS.
     
  8. ChrazzyChris

    ChrazzyChris New Member

    I narrowed the problem down to the 100-sitename.conf file in the /etc/apache2/sites-enabled/ folder having the following line that causes an error now after the original update this morning.

    Code:
    FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php
    So if I put a hash to remark it out, and restart apache2 it starts up ok, but now whenever I try to go to the site, rather than displaying the webpage, it just wants to download the page in the browser. :(
     
  9. ChrazzyChris

    ChrazzyChris New Member

    ... and when I run step 14.2...

    Code:
    [email protected]:/etc/apache2/sites-enabled# apt-get install libapache2-mod-fastcgi php5-fpm
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    php5-fpm is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     libapache2-mod-fastcgi : Depends: apache2.2-common (>= 2.2.4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
     
  10. ChrazzyChris

    ChrazzyChris New Member

    For what is was worth...

    Code:
    [email protected]:/etc/apache2/sites-enabled# aptitude install apache2 apache2-suexec libapache2-mod-fcgid php5-cgi
    The following NEW packages will be installed:
      apache2-suexec apache2-suexec-pristine{a} apache2.2-common{ab} libapache2-mod-fcgid 
    0 packages upgraded, 4 newly installed, 0 to remove and 3 not upgraded.
    Need to get 365 kB of archives. After unpacking 1,271 kB will be used.
    The following packages have unmet dependencies:
     apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to be installed.
                        Depends: apache2-utils but it is not going to be installed.
     apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
    The following actions will resolve these dependencies:
    
         Keep the following packages at their current version:
    1)     apache2.2-common [Not Installed]                   
    2)     libapache2-mod-fcgid [Not Installed]               
    
    
    
    Accept this solution? [Y/n/q/?] 
    The following NEW packages will be installed:
      apache2-suexec apache2-suexec-pristine{a} 
    0 packages upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
    Need to get 70.3 kB of archives. After unpacking 168 kB will be used.
    Do you want to continue? [Y/n/?] 
    Get: 1 http://ppa.launchpad.net/ondrej/php5/ubuntu/ precise/main apache2-suexec-pristine amd64 2.4.9-1+deb.sury.org~precise+1 [68.9 kB]
    Get: 2 http://ppa.launchpad.net/ondrej/php5/ubuntu/ precise/main apache2-suexec amd64 2.4.9-1+deb.sury.org~precise+1 [1,398 B]
    Fetched 70.3 kB in 0s (626 kB/s)     
    Selecting previously unselected package apache2-suexec-pristine.
    (Reading database ... 100811 files and directories currently installed.)
    Unpacking apache2-suexec-pristine (from .../apache2-suexec-pristine_2.4.9-1+deb.sury.org~precise+1_amd64.deb) ...
    Selecting previously unselected package apache2-suexec.
    Unpacking apache2-suexec (from .../apache2-suexec_2.4.9-1+deb.sury.org~precise+1_amd64.deb) ...
    Processing triggers for man-db ...
    Setting up apache2-suexec-pristine (2.4.9-1+deb.sury.org~precise+1) ...
    update-alternatives: using /usr/lib/apache2/suexec-pristine to provide /usr/lib/apache2/suexec (suexec) in auto mode.
    Setting up apache2-suexec (2.4.9-1+deb.sury.org~precise+1) ...
                                             
    [email protected]:/etc/apache2/sites-enabled# aptitude install apache2 apache2-suexec libapache2-mod-fcgid php5-cgi
    The following NEW packages will be installed:
      apache2.2-common{ab} libapache2-mod-fcgid 
    0 packages upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
    Need to get 295 kB of archives. After unpacking 1,103 kB will be used.
    The following packages have unmet dependencies:
     apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to be installed.
                        Depends: apache2-utils but it is not going to be installed.
     apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
    open: 23; closed: 75; defer: 3; conflict: 3                                                                                                                                .The following actions will resolve these dependencies:
    
         Keep the following packages at their current version:
    1)     apache2.2-common [Not Installed]                   
    2)     libapache2-mod-fcgid [Not Installed]               
    
    
    
    Accept this solution? [Y/n/q/?] 
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    Need to get 0 B of archives. After unpacking 0 B will be used.
                                             
    [email protected]:/etc/apache2/sites-enabled# aptitude install apache2 apache2-suexec libapache2-mod-fcgid php5-cgi
    The following NEW packages will be installed:
      apache2.2-common{ab} libapache2-mod-fcgid 
    0 packages upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
    Need to get 295 kB of archives. After unpacking 1,103 kB will be used.
    The following packages have unmet dependencies:
     apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to be installed.
                        Depends: apache2-utils but it is not going to be installed.
     apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
     apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.
    open: 23; closed: 75; defer: 3; conflict: 3                                                                                                                                .The following actions will resolve these dependencies:
    
         Keep the following packages at their current version:
    1)     apache2.2-common [Not Installed]                   
    2)     libapache2-mod-fcgid [Not Installed]               
    
    
    
    Accept this solution? [Y/n/q/?] n
    The following actions will resolve these dependencies:
    
         Remove the following packages:                                                                                           
    1)     apache2-bin                                                                                                            
    2)     apache2-data                                                                                                           
    3)     apache2-suexec-pristine                                                                                                
    4)     libapache2-mod-php5                                                                                                    
    
         Install the following packages:                                                                                          
    5)     apache2-mpm-event [2.2.22-1ubuntu1.5 (precise-security, precise-updates)]                                              
    6)     apache2-utils [2.4.9-1+deb.sury.org~precise+1 (precise)]                                                               
    7)     apache2.2-bin [2.2.22-1ubuntu1.5 (precise-security, precise-updates)]                                                  
    
         Downgrade the following packages:                                                                                        
    8)     apache2 [2.4.9-1+deb.sury.org~precise+1 (now, precise) -> 2.2.22-1ubuntu1.5 (precise-security, precise-updates)]       
    9)     apache2-suexec [2.4.9-1+deb.sury.org~precise+1 (now, precise) -> 2.2.22-1ubuntu1.5 (precise-security, precise-updates)]
    
    
    
    Accept this solution? [Y/n/q/?] 
    The following packages will be DOWNGRADED:
      apache2 apache2-suexec 
    The following NEW packages will be installed:
      apache2-mpm-event{a} apache2-utils{a} apache2.2-bin{a} apache2.2-common{a} libapache2-mod-fcgid 
    The following packages will be REMOVED:
      apache2-bin{a} apache2-data{a} apache2-suexec-pristine{a} libapache2-mod-php5{a} 
    0 packages upgraded, 5 newly installed, 2 downgraded, 4 to remove and 3 not upgraded.
    Need to get 1,789 kB of archives. After unpacking 8,914 kB will be freed.
    Do you want to continue? [Y/n/?] 
    Get: 1 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/universe apache2-suexec amd64 2.2.22-1ubuntu1.5 [15.4 kB]
    Get: 2 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main apache2 amd64 2.2.22-1ubuntu1.5 [1,494 B]
    Get: 3 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main apache2.2-bin amd64 2.2.22-1ubuntu1.5 [1,339 kB]
    Get: 4 http://ppa.launchpad.net/ondrej/php5/ubuntu/ precise/main apache2-utils amd64 2.4.9-1+deb.sury.org~precise+1 [136 kB]
    Get: 5 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main apache2-mpm-event amd64 2.2.22-1ubuntu1.5 [2,360 B]
    Get: 6 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main apache2.2-common amd64 2.2.22-1ubuntu1.5 [226 kB]
    Get: 7 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/universe libapache2-mod-fcgid amd64 1:2.3.6-1.1ubuntu0.1 [69.0 kB]
    Fetched 1,789 kB in 0s (7,630 kB/s)        
    (Reading database ... 100812 files and directories currently installed.)
    Removing libapache2-mod-php5 ...
    php5_invoke prerm: Disable module mysqli for apache2 SAPI
    php5_invoke prerm: Disable module imap for apache2 SAPI
    php5_invoke prerm: Disable module opcache for apache2 SAPI
    php5_invoke prerm: Disable module gd for apache2 SAPI
    php5_invoke prerm: Disable module pdo for apache2 SAPI
    php5_invoke prerm: Disable module imagick for apache2 SAPI
    php5_invoke prerm: Disable module json for apache2 SAPI
    php5_invoke prerm: Disable module curl for apache2 SAPI
    php5_invoke prerm: Disable module mysql for apache2 SAPI
    php5_invoke prerm: Disable module xcache for apache2 SAPI
    php5_invoke prerm: Disable module pdo_mysql for apache2 SAPI
    php5_invoke prerm: Disable module mcrypt for apache2 SAPI
    Module php5 disabled.
    apache2_invoke prerm: Disable module php5
    Action 'configtest' failed.
    The Apache error log may have more information.
    apache2_reload: Your configuration is broken. Not restarting Apache 2
    dpkg: warning: downgrading apache2-suexec from 2.4.9-1+deb.sury.org~precise+1 to 2.2.22-1ubuntu1.5.
    dpkg: regarding .../apache2-suexec_2.2.22-1ubuntu1.5_amd64.deb containing apache2-suexec:
     apache2-suexec conflicts with apache2-suexec
      apache2-suexec-pristine provides apache2-suexec and is present and installed.
    dpkg: error processing /var/cache/apt/archives/apache2-suexec_2.2.22-1ubuntu1.5_amd64.deb (--unpack):
     conflicting packages - not installing apache2-suexec
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     /var/cache/apt/archives/apache2-suexec_2.2.22-1ubuntu1.5_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Didn't do anything positive :'(
     
  11. ChrazzyChris

    ChrazzyChris New Member

    O...M...G... I think I have sorted it, it's not 100% back, but jeez what a half day of sweaty mc face plants!

    OK so what I did in the end was add the repository for a different version of Apache2...

    Code:
    add-apt-repository ppa:ondrej/apache2
    (ref: http://stackoverflow.com/questions/21390544/installing-apache-2-4-and-php-5-5-on-ubuntu-12-04)

    Then I just followed the instructions 1-3 from http://ubuntuforums.org/showthread.php?t=1038416

    and then ...

    in the folder /etc/apache2/sites-enabled i created a symlink to the ispconfig vhosts file

    Code:
    ln -s /etc/apache2/sites-available/ispconfig.vhost /etc/apache2/sites-enabled/000-ispconfig.conf
    Then restarting apache...

    Code:
    service apache2 restart
    finally this seemed to allow me to access my ISPconfig interface (phew).

    After logging into ISPConfig, I went straight to the Tools tab and ran a resync on the websites... and after a few minutes, the /etc/apache2/sites-enabled folder was once more populated with my sites and symlinks.

    Most of the sites seem now to work, bar a couple with are giving me an error 500... so I will be looking into that shortly.

    I was seriously expecting to be up half the night pulling my hair out with this... but I was so lucky to find things to try that actually worked without breaking it further.

    Now, the next thing I want to figure out is how to do a complete backup of the server so if it went t!t$ up again or worse, how I can just wipe and start again, and restore the server completely.

    Perhaps a VM would be better and using my server as a host server, that way I could just backup the VM and it wouldn't be so hard to do a full restore?

    Idea's please, and suggestions... I never got VM's to work so a little confused.

    thanks again guys.
     
  12. Haringstad

    Haringstad New Member

    What helped me, was going to Extra, and sync the websites. After you checked the configuration-style for Apache in your server config. This will rebuild all the apache configuration files for you, in new-style.
     

Share This Page