Display error with Server Monitoring With munin

Discussion in 'HOWTO-Related Questions' started by fher98, Jun 11, 2007.

  1. fher98

    fher98 New Member

    Hi, I read your "Server Monitoring With munin And monit On Debian Etch" (pretty nice) I installed it but when i try to see the output on my browser i get this error

    Parse error: syntax error, unexpected T_STRING in /var/www/monitoring/index.html on line 1

    Ok, so I check index page that was generated and delete the first line that reads:

    <?xml version="1.0" encoding="iso-8859-1"?>

    Then, without this line it works, but all the pages in the links have the same problem... sooo I wento to good old google.. and I found thats something to do with apache2 and XHTML 1.1, but cant seem to find the answer..

    Can someone help me out please,.. thanks
  2. Leszek

    Leszek New Member


    Did You install "perl-HTML-Template" ?
  3. fher98

    fher98 New Member

    thanks for your response, Im running Debian and I do have libhtml-template-perl installed, what else could it be?
  4. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you followed the tutorial as close as possible? It's working for me.
  5. fher98

    fher98 New Member

    Yeah... welll it runs and creates the pages... with the described error, on the other hand I just intalled munin... on Debian Lenny,.. monit still pending... ill erase it and try again tonight..

    Thanks for your respond Falko
  6. fher98

    fher98 New Member

    The installation works excellent in Debian Etch... but I cant seem to resolve the issue in Lenny... very strange...

    Any ideas?

  7. gAnDo

    gAnDo New Member

    I found setting short_open_tag to Off in php.ini solved this problem.
    Not sure why but it did the trick for me :p

Share This Page