Discourse & ISPConfig @debian/nginx

Discussion in 'Installation/Configuration' started by Neptun, Jul 2, 2019.

  1. Neptun

    Neptun Member

    Dear all,
    i hope somebody could help to get discourse working together with ispconfig at an debian server with nginx setup (perfect server tut from here).

    I have used this tutorial:
    https://www.howtoforge.com/how-to-install-discourse-forum-on-ubuntu-1804/
    With some workaround the setup was successful - i have installed the ruby setup at the ispconfig given document root with the needed db postgres - all accepted.

    BUT

    i'm not able to get the Discourse web interface working - whole time -> error 403 - everything is set with correct linux user & owner
    This is the only error shown in server logs:

    Code:
    [error] 24963#24963: *2301 directory index of "/var/www/domain.com/web/" is forbidden, client: 89.215.2.9, server: domain.com, request: "GET / HTTP/1.1", host: "domain.com"
    I think the issue is anywhere in the nginx vhost configs of ispconfig together with the /etc/nginx/conf.d/discourse.conf from the setup
    - but i cannot find it ....

    Hopefully somebody has an idea how to fix it.

    Thanks in advance
     
    Last edited: Jul 2, 2019
  2. Neptun

    Neptun Member

    i have tried now also the setup of discourse outside of the ispconfig document roots
    -> install now at /var/www/discourse
    everything fine so far - but when i try to open Discourse web interface -> now no 403 error

    BUT - only forwarded from the subdomain to the main domain & it shows the content of the main domain .... no errors in server logs anywhere ..... :(:confused:
     
  3. Neptun

    Neptun Member

    New day - new try

    Now with docker install & reverse proxy for nginx / discourse

    everything perfect without any issue - BUT again -> the subdomain get forwarded to the main domain & shows this content of my wordpress install and not the installed & working discourse container via docker
    also nothing in logfiles which could help to find the issue

    @till
    could you kindly help here to get discourse working with nginx & ispconfig
    i have no idea anymore how to get it working

    thank you so much in advance
     
  4. ahrasis

    ahrasis Well-Known Member

  5. Neptun

    Neptun Member

    I have tried now different ways:

    1.) without docker
    tried this two guides which are almost the same
    https://www.howtoforge.com/how-to-install-discourse-forum-on-ubuntu-1804/
    &
    https://www.linuxbabe.com/ubuntu/install-discourse-ubuntu-18-04-server-without-docker/amp

    - way a - at ispconfig document root
    with subdomain setup as own website
    -> no chance - error 403

    - way b - at /var/www/discourse
    -> subdomain in use get forwarded to main domain & shows content of wordpress which is setup at ispconfig


    2.) with docker & with reverse proxy
    by usage of this tutorial
    https://www.howtoforge.com/tutorial...re-discourse-forum-with-nginx-on-ubuntu-1604/

    - situation a
    -> subdomain again forwarded to main domain & shows content of wordpress which is setup at ispconfig

    - situation b
    with added location/reverse proxy settings to ispconfig nginx options @ control panel ispconfig
    no forward to main domain
    but style broken, shows admin register form (1st step) / only correct shown when try sub.domain.com:2045

    -> after try to register admin account - partial broken, not working js & buttons not usable to reconfirm admin user registration
    -> try of subdomain without the admin confirm link page - blank page
    -> when i try to complete admin account via ruby/ssh - also change to blank page


    3.) with or without docker at own server
    - no additional nginx reverse proxy in use, without ispconfig or other panel
    - also same subdomain in use

    -> working
     
    Last edited: Jul 4, 2019
  6. ahrasis

    ahrasis Well-Known Member

    Your subdomain works at own server could mean many things on why it doesn't work on other server, one of which could be its dns and vhost settings.

    Finally, I never try discourse, so I can't help further but in my experience, normaly tutorials in here work just fine.
     
  7. Neptun

    Neptun Member

    The tutoriales what you can find here are really good - ok you will never find everthing for your os - but you should be able to modify this for your own needs

    I had another admin panel before und changed now also here to IspConfig - much better then before as well you find here a lot which helps

    Discourse would be perfect together with my wordpress page - at the moment i change the server and therefore i can play & test around what is working or not - and i have found until now nothing what is working together with IspConfig
    There servers are nearly 1:1 the same - the new one has more power and everything will be better with everything up to date - with the old setup & admin panel a lot was not possible - development is 2 years behind

    With IspConfig it is a great enjoyment at the moment - because you get nearly everything working - the only thing where i have an issue is Discourse at the moment

    Hopefully somebody could help to get it working

    I think the only reason for the issues are the vhost settings only which must be partial applied to IspConfig control panel at nginx options
     

Share This Page