Disable /phpmyadmin and /webmail URL for sites

Discussion in 'Installation/Configuration' started by zion, Nov 27, 2013.

  1. zion

    zion New Member

  2. JeGr

    JeGr Member

    As I don't know how you included roundcubemail in your setup, that would be a bit vague. Same for phpmyadmin, as you don't even specify what OS you are on. In perfect server howtos, phpmyadmin is installed via OS package managers most of the times so it has an extra configuration for apache, that has to be edited or disabled to not be available on all vhosts.

    On Debian/Ubuntu that would be:

    /etc/apache2/conf.d/phpmyadmin.conf (or conf-available if you are on newer apache versions)

    There, an alias is declared system wide (and not only inside a Virtualhost directive). If you comment that and include it in the vhost you want, that should take care of your problem for phpmyadmin.

    Another option would be to simply uninstall the OS-based phpmyadmin with your package manager of choice and install the tar.gz or zip archive from phpmyadmin.net into the domain/vhost you want it to run by yourself. But think twice about that as packages like phpmyadmin or roundcube are things that change often and can contain bugs so if you uninstall the OS package and install it yourself, you also have to take care and update it yourself!

    Greets
     
  3. zion

    zion New Member

    Dear Grey,

    You have absolutely right :)
    OS: Debian 7.2
    phpmyadmin and roundcube was installed via aptitude package manager

    I commented out Alias 'phpmyadmin' from /etc/apache2/conf.d/phpmyadmin.conf and 'webmail' from /etc/apache2/conf.d/roundcube and included in /etc/apache2/sites-available/ispconfig.vhost

    Now http://website.tld/phpmyadmin and http://website.tld/webmail gives 'Page not found', and https://myserver.tld/phpmyadmin and https://myserver.tld/webmail give webapps login page as I expected.

    Thank you very much for your help!
     

Share This Page