Disable PHP Mail Functions

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Sep 27, 2017.

  1. pawan

    pawan Member HowtoForge Supporter

    First I tried to disable mail functions using the
    disable_funtions = mail
    1. custom.ini setting in options for the website. -No effect.
    2. edited php.ini in /opt/phpfcgi-5.4.45/lib - No effect
    3. rsync the website using tools in ispconfig - No effect
    Physically checked the loaded.ini in /var/www/conf/web10/php.ini, the line
    disable_funtions = mail
    is there, but in phpinfo it says `no value`
    Also I noted the in
    /var/www/php-fcgi-scripts/web10/.php-fcgi-starter
    there is a entry, which reads like
    Code:
    exec /opt/phpfcgi-5.4.45/bin/php-cgi \
     -d open_basedir="/var/www/clients/client4/web10/web:/var/www/clients/client4/web10/tmp:/var/www/mydomain.com/web:/srv/www/mydomain.com/web:/usr/s$
    -d disable_functions="" \
    
    I think the line disable_functions="" should be disable_functions=mail

    Or may be I am not getting it correctly.
    but the changes I am making is not getting reflected.
     
  2. HSorgYves

    HSorgYves Active Member HowtoForge Supporter

    Which php mode are you using?
     
  3. pawan

    pawan Member HowtoForge Supporter

    fastcgi
     
  4. pawan

    pawan Member HowtoForge Supporter

    I don't why this is happening, but if I modify the file manually like:
    -d disable_functions="" \
    to
    -d disable_functions="mail" \
    it reflects in the phpinfo()
    I don't think this is the normal behavior.
     
  5. HSorgYves

    HSorgYves Active Member HowtoForge Supporter

    EDIT:
    You are right, I created my own php-fcgi-starter.master in ./server/conf-custom without that line. Forgot about it :(
     
    Last edited: Sep 27, 2017
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I removed that line from fcgi starter now.
     
    HSorgYves likes this.

Share This Page