Disable functions not working

Discussion in 'Installation/Configuration' started by mislav, May 4, 2017.

  1. mislav

    mislav Member

    Hi.
    OS - Debian 7, wheezy
    ISpconfig - 3.1.2.

    As far as I recall, this was working just fine in previous ispconfig version. For some reason, disable_functions is no longer working. It says "no value" in phpinfo, even though default disable_functions exist:
    disable_functions = pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,

    If I try to put under website options tab, e.g. disable_functions = mail with or without quotes, it doesn't work, it still says no value. What I'm doing wrong?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which PHP mode do you use? The php ptions can be used only in php modes: FPM, FCGI and CGI.
     
  3. mislav

    mislav Member

    Fast-CGI is used on all. If I e.g. add under options memory_limit to be 256M, that works, but disable_functions does not.
     
  4. mislav

    mislav Member

    Anyone? I'm still having this problems.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the generated custom php.ini file for that website, the directive can be found at the end of the file.
     
  6. mislav

    mislav Member

    Value is there, same as any other variable I add. So e.g. php.ini in /var/www/conf/webX/php.ini contains at the bottom:
    disable_functions = mail
    memory_limit = 128M
    and only memory limit is affected - functions says "no value".
     
  7. mislav

    mislav Member

    @till is it not working because of this:
    https://git.ispconfig.org/ispconfig/ispconfig3/issues/4448
    It would make sense - because anything you put inside in ispconfig, it is overwritten by this setting. I can confirm this is only in Ispconfig 3.1.
    Bug? Why ispconfig doesn't allow us to manage this like before?
     

Share This Page