Disable FTP plain text password Pure-ftpd

Discussion in 'Installation/Configuration' started by Jeremy007, Jul 20, 2021 at 1:53 PM.

  1. Jeremy007

    Jeremy007 Member

    Hello HTF Friends,

    Setup : Multi-server
    OS : Ubuntu 18.0.4
    Server type : Nginx/1.18.0
    Databse : mySql

    I need to disable the use of plain text passwords for ftp but can't seem to find the config to do so. Or maybe just disable ftp and only allow ftps. Does anyone know how to get this done?

    Cheers
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's what I would recommend. A Plaintext password is no issue when used over a secure SSL/TLS channel. To allow SSL sessions only, run:

    echo 2 > /etc/pure-ftpd/conf/TLS

    and then restart pure-ftpd-mysql
     
    Jeremy007 likes this.
  3. Jeremy007

    Jeremy007 Member

    Got it. I was trying "pure-ftpd" instead of "pure-ftpd-mysql" restart. Thanx Till
     

Share This Page