disable 2.6 kernel modules during bootup

Discussion in 'Installation/Configuration' started by ryoken, Feb 14, 2006.

  1. ryoken

    ryoken New Member

    does anyone know how to disable or turn off linux 2.6 kernel modules so that it doesn't load at startup? this question is for linux 2.6 (not 2.4) because in Debian 3.1 "Sarge", modules.conf is deprecated and has been replaced by modprobe.conf (or the directory /etc/modprobe.d). in the past, you would simply edit the modules.conf file and append "alias modulename off". this is no longer the case. if i add this line to a file in /etc/modprobe.d/, it thinks "off" is the unabbrievated module name of "modulename" (see man page of modprobe for further details).

    i have also tried disabling the module in "hotplug" (using the blacklist) and skipping the module in /etc/discover.conf to no avail. :mad:

    any suggestions would be much appreicated!

    ps - the last thing i want to do is rename the module i want to disable (so that other programs can't find it)!
  2. falko

    falko Super Moderator ISPConfig Developer

    Is the modules listed in /etc/modules? If so, remove it from there.
  3. ryoken

    ryoken New Member

    unfortunately, the module i want to disable called "forcedeth" isn't listed in /etc/modules :(
  4. ryoken

    ryoken New Member

    hmm... i just renamed the kernel module from "forcedeth.ko" to "_forcedeth.ko", but while booting, it still says its already loaded (according to hotplug).

    i am still using "skip forcedeth" in discover, and have blacklisted "forcedeth" in hotplug, but its still loading. i checked dmesg, and "forcedeth.c" is loaded quite early in the boot process (looks like before or around the same time as when the hard drive PIO/DMA modes are detected.

    does the mean that forcedeth has been statically loaded in the kernel? if so, how do i stop it from loading during bootup? i want to install the nVidia nForce drivers, and according to their documentation (http://download.nvidia.com/XFree86/nforce/1.0-0310/ReleaseNotes.html), you must disable forcedeth first.

    strangely enough, i can use "modprobe -r forcedeth" when logged into Linux. so is forcedeth a kernel module or has it been statically built into the kernel? running "ifconfig -a" confirms that "eth0" no longer exists. but after rebooting, forcedeth is loaded in again, and eth0 is up.

    any suggestions?

Share This Page