directory listing

Discussion in 'Installation/Configuration' started by cafeelgood, Nov 11, 2007.

  1. cafeelgood

    cafeelgood New Member

    I would like one of my sites to be listed by apache, like it is only a document server. I am trying to enable this with the apache directives:

    <Directory '/home/server01/web2/web/'>
    Options Indexes

    But it ain't working. Is it because ispconfig is generating by itself a index.html??
    If so, what can I do?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try:

    <Directory '/home/server01/web2/web/'>
    Options +Indexes

    Yes.This might be the problem too.

    Use a subdirectory for example. Or change the ISPConfig code that copies the index files.
  3. cafeelgood

    cafeelgood New Member

    So I used the specified text, but it gaved nothing. I also used a sub directory called logiciel:

    <Directory '/home/server01/web2/web/logiciel/'>
    Options +Indexes

    and tried to acces it at

    But it would respond by a connexion reinitialized (never loaded).

    Any other idea, since this is a clean install??

    Thanks for you reply till!
  4. edge

    edge Active Member Moderator

    Not sure if it makes any difference to you, but replace the ' with a " , and remove the / after logiciel
    <Directory "/home/server01/web2/web/logiciel">
    Options +Indexes
    I've got it like that working on my servers.
    An other thing could be the path.
    On my servers they are all set from the root dir

    <Directory "/var/www/web28/web">
  5. cafeelgood

    cafeelgood New Member

    Still the same problem.

    <Directory "/home/server01/www/web2/web">
    Options +Indexes

    to access

    I know it is not a question of internet link, because everything else is working (ftp, etc). But as I am thinking to it, i can't see the index.html automatically created by ispconfig. I will look on this side.
  6. falko

    falko Super Moderator ISPConfig Developer

    Have you tried this without any quotation marks?
  7. cafeelgood

    cafeelgood New Member

    I do have now, but I still can't get it to work. I only see the automatic web page from ispconfig. How can I disable it?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the page and try again.
  9. cafeelgood

    cafeelgood New Member

    All right! everything is fine! but will this index.html come back by its own once again? Because i already deleted it like 3 times!

  10. edge

    edge Active Member Moderator

    In ISPconfig, goto ISPconfig, and select the site in question.
    Now goto the tab DirectoryIndex, and remove the index.html from it.

    This should stop it being auto generated.
  11. cafeelgood

    cafeelgood New Member

    Effectively, it seems to work for now!

    Thanks for everything!

Share This Page