Difficulties to create a secondary DNS zone

Discussion in 'Installation/Configuration' started by Khayo, Mar 3, 2012.

  1. Khayo

    Khayo New Member

    I am struggling to create a secondary DNS zone in ISPConfig3
    On the principal server, the domain is responding OK. On the secondary server it creates an entry in /etc/bind/named.conf.local, which points to a file /etc/bind/slave/sec.example.tld, but this file is not created automatically. Is this correct or was some misconfiguration?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution? Are there any errors in your logs? What's the output of
    Code:
    ls -la /etc/bind/slave
    ?
     
  3. Khayo

    Khayo New Member

    In the two servers I am using Ubuntu 10.04
    Output from
    secondary
    primary
    Where I see the log?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    chmod g+w /etc/bind/slave
    on the slave.
     
  5. Khayo

    Khayo New Member

    It did not work
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Are there any named errors in your logs (on the master and on the slave)?
     
  7. Khayo

    Khayo New Member

    Where can I find this log?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    On Debian and Ubuntu it is /var/log/syslog
     
  9. Khayo

    Khayo New Member

    master
    slave
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you added the IP adress of the slave in the "Allow zone transfers to
    these IPs (comma separated list)" field of the zone settings.
     
  11. Khayo

    Khayo New Member

    master
    slave
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I explained the setting which is missing in your server in #10 of this thread. If you dont allow zone transfers, then they will not work.
     
  13. Khayo

    Khayo New Member

    but I allow zone transfers
    [​IMG]
    [​IMG]
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to add the IP of the secondary server in the primary zone settings as described in my other post. But you added them in the settings of the slave zone.
     
  15. Khayo

    Khayo New Member

    Thank you! It worked! It was just this setting that was missing! thank you very much
     

Share This Page