Did I kill Joomla?

Discussion in 'General' started by rabrol, Nov 15, 2007.

  1. rabrol

    rabrol New Member

    Hi all.

    I recently did a number of upgrades.
    1. I upgraded the base Ubuntu install.
    2. I upgraded ISPConfig to latest stable version.
    3. I opened up Port 80 (had been 800 during testing)

    Then I set up some new domains, transferred a bunch of stuff and smiled as the testing server became production.

    Then last night I tried to access a Joomla test site I have been working on. It was unavailable. I can connect to the site itself, but then Joomla takes forever to load a page that says it is offline. The title at the top of the page is correct, but it says "Could not connect to the database server". It had been working fine prior to the upgrades (which included a MySQL upgrade at apt-get upgrade level I think).

    I restarted (as in rebooted) the server, but it made no difference. Joomla is still offline.

    I logged in to PHPmyadmin. There I can select databases to view, but the only options are information_schema, ispconfigdb or mysql. There is no mention of Joomla anywhere. I don't know what to do next?

    Rob
     
  2. rabrol

    rabrol New Member

    I notice in var/web/web5 (the joomla directory) there is a file called joomla.sql which I assume is my database. Why is it not showing in phpmyadmin? Can I import it or something?

    Rob
     
  3. till

    till Super Moderator

    I dont think that this file contains your database. It is the mysql dump that is used by the joomla installer to install the databases for new joomla versions.

    Please post the output of:

    ls -la /var/lib/mysql/
     
  4. rabrol

    rabrol New Member

    xxxxxxx@WebServer:~$ ls -la /var/lib/mysql/
    total 20540
    drwxr-xr-x 4 mysql mysql 4096 2007-11-14 17:33 .
    drwxr-xr-x 26 root root 4096 2007-11-12 22:32 ..
    -rw-r--r-- 1 mysql mysql 0 2007-11-12 22:32 debian-5.0.flag
    -rw-rw---- 1 mysql mysql 10485760 2007-11-14 17:33 ibdata1
    -rw-rw---- 1 mysql mysql 5242880 2007-11-14 17:33 ib_logfile0
    -rw-rw---- 1 mysql mysql 5242880 2007-05-03 15:37 ib_logfile1
    drwx------ 2 mysql mysql 4096 2007-11-13 09:46 ispconfigdb
    drwxr-xr-x 2 mysql mysql 4096 2007-11-14 17:05 mysql
    lrwxrwxrwx 1 mysql root 27 2007-05-04 16:23 mysql.sock -> /var/run/mysqld/mysqld.sock
    -rw------- 1 mysql mysql 4 2007-05-03 15:37 mysql_upgrade.info

    The upgrade.info file just contains the version number 5.0
    It looks as if the Joomla database is absent. But I don't know why - do upgrades (OS level or ISPConfig) typically mess with mysql databases?

    Actually I may have done a stupid thing. When I tried to access Joomla and it couldn't connect to the database, I happened to have ISPConfig open in another browser tab. I checked to see if MySQL access was granted for the domain (it was). Then (perhaps foolishly) I unchecked the box, saved, and rechecked the box, thinking I could maybe kick start mysql if that is where the problem lay. Could that be why it is missing? If so, would it be backed up anywhere?

    Rob
     
  5. falko

    falko Super Moderator

    Did you create a database for that web site in ISPConfig (you can do that on the Options tab)?

    After you've created it, you can import the .sql file like this: http://www.howtoforge.com/faq/6_4_en.html
     
  6. rabrol

    rabrol New Member

    Thanks for that Falko! Now I've just got to find the config file that tells Joomla where to look for the db!

    Rob
     
  7. rabrol

    rabrol New Member

    Well the config file was easy to find, and she is now up and running nicely again. Its just a shame by backup of the database is 3 month old.

    Robin
     

Share This Page