Diagnostic-Code: X-Postfix; mail for .. loops back to myself

Discussion in 'Installation/Configuration' started by wp.rauchholz, Jan 12, 2017.

  1. wp.rauchholz

    wp.rauchholz New Member

    Now I know that this topic has already been discussed a few times, but I do not seem to find the solution. Hence my question.
    I run a home serve under CENTOS 7, postfix/dovecot. I can send send emails outside. Only when sending a mail to my server I get this message.
    I have an dynamic IP, single domain.
    I played with mynetworks and smtp_bind_address. But I am not able to fix it.
    Currently they are set as:
    mynetworks = XX.5.2.0/24, 127.0.0.0/8
    smtp_bind_address = XX.5.2.1
    mydomain = wo-lar.com
    /etc/hosts
    XX.5.2.1 home.wo-lar.com home
    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

    /etc/sysconfig/network
    NETWORKING=yes
    HOSTNAME=home.wo-lar.com
    GATEWAYDEV=enp6s0
    ZEROCONF=yes

    The named zoone file has this entry
    IN MX 10 home ; Mail Exchange

    There is no error message in /var/log/maillog


    This is the mail system at host mailfwd1.zoneedit.com.
    ...
    <wp.rauchholz@wo-lar.com>: mail for wo-lar.com loops back to myself
    Final-Recipient: rfc822; wp.rauchholz@wo-lar.com
    Original-Recipient: rfc822;wp.rauchholz@wo-lar.com
    Action: failed
    Status: 5.4.6
    Diagnostic-Code: X-Postfix; mail for wo-lar.com loops back to myself

    Any help is very welcome.
    Wolfgang
     
  2. wp.rauchholz

    wp.rauchholz New Member

    Some more info. I found a webpage to troubleshoot Postfix. I must have a problem with my network, but not sure what:
    1) # telnet relay-test.mail-abuse.org - gives following result:
    Trying 168.61.4.13...
    telnet: connect to address 168.61.4.13: Connection timed out
    2)# host relay-test.mail-abuse.org
    relay-test.mail-abuse.org is an alias for cygnus.mail-abuse.org.
    cygnus.mail-abuse.org has address 168.61.4.13
    3) ping 168.61.4.13 returns only this, and then it stops. PING 168.61.4.13 (168.61.4.13) 56(84) bytes of data.


     
  3. wp.rauchholz

    wp.rauchholz New Member

    SOLVED.... it was a zoneedit.com email setup error......
    I had pointing the email service to zoneedit as mail server insted of pointing to my own one....

    Wolfgang
     
    till likes this.

Share This Page