Development Server

Discussion in 'General' started by sabramedia, Feb 6, 2007.

  1. sabramedia

    sabramedia New Member

    I have successfully installed ISPConfig on Suse Linux 9.3. What a chore. I learned a lot though. Now my question(s) is as follows:

    The linux box that ISPConfige is setup on is going to operate as our Dev Server. We are using a router for our network and internet... The router dynamically assigns IP addresses for all our local machines. The router is set NOT to dynamically assign to the IP range - What I envisioned is using that range for testing multiple websites internally. We type in the IP address which points to the internal folder on the linux box. Here is what we have done so far.

    • Successfully accessed, via HTTP, the linux box default server website home page (
    • Added a test IP address to the network card in Yast (
    • Added the previous IP to ISPConfig > Management > Server > Settings in the IP List field
    • Associated a website with the IP address
    • Successfully uploaded a website to to the correct 'www' folder

    Our problem is when we go to access the IP address via We are forwarded to the shared IP folder where a page says:

    "This IP address is shared. For access to the web site which you look for, enter its address instead of its IP."

    Should I customize an entry in httpd.conf or the ispconfig_vhost.conf file? Is there a better method or program that will help me accomplish the objectve?

    Thanks for your help...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use ISPConfig with IP based vhosts.

    The solution is to create internal domains for the websites like that you configure on the nameserver on the ISPConfig box. Then configure your workstations to use the ISPConfig nameserver as default nameserver.
  3. sabramedia

    sabramedia New Member

    It Works in Part

    That works well for HTTP. Thanks. However, FTP does not route properly.

    When accessing or through a browser I am forwarded to the root FTP location ( /srv/ftp ) rather than the site's root FTP location ( /srv/www/web1 ).

    Also, when I try to login via the Web-FTP tool it gives me the following error:
    "Could not connect as user web1_username".

    When using a third party FTP client I get an "Access Denied" error message.

    Am I missing something?
  4. falko

    falko Super Moderator ISPConfig Developer

    You must log in with the right username. If you log in with the administrator of web1, you will get to /srv/www/web1.

    Did you enable FTP for that web site?
    What's the entry for web1_username in /etc/passwd?
  5. sabramedia

    sabramedia New Member

    The login prompt doesn't even come up when I use a browser. It just opens up into the FTP folder /srv/ftp.

    Yes. FTP is enabled.

    Entry for web1_username is:

    ..... /srv/www/web1:/bin/false
  6. sabramedia

    sabramedia New Member

    Finally figured out my problem. For anyone who doesn't want to spend a day banging their on this.... Make sure no other FTP servers are running. I forgot that I had setup vsftpd a couple days ago. It was still running. I turned it off and proftpd works like a pro!
  7. dangeorge6

    dangeorge6 New Member

    Hi Till,

    I'm having the same issue but I dont' know how to set up an internal domain. I just have a single ISP box at home behind a router on a LAN and I want to be able to access my sites in development from any computer on the LAN. Can this be done just through steps in ISPconfig? Do I have to register a domain, etc? Sorry for the noobness!

  8. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Run a local copy of bind, and manage a non-official domain like myhomelan.loc. Don't do the zonetransfers and the upstream DNS servers will be happy also. You need to tweak the base ISPConfig templates.

    Another method is to create local /etc/hosts files (even for Windows) on the clients on your lan and have those point to your home server.
    /etc/hosts web1.myhomeserv.loc web2.myhomeserv.loc
    You can even do name based hosting this way. Drawback with the 1st solution: need to edit an /etc/hosts file on every client. Advantage: simplicity.
  9. sabramedia

    sabramedia New Member


    I have the same setup scenario you mentioned (router, LAN, ISP box, etc). ISPConfig is now working on my LAN based on Till's advice. Here is what worked for me.

    My ISPConfig box, Suse Linux 9.3, has a set internal IP address of, which also has a DNS server running on it. I have WinXP workstations that connect to the router that the SuseLin server connects to. On the workstations I went into Network Card > TCP/IP and set the "Preferred DNS server" to my SuseLin address ( It then checks there first for DNS settings.

    On the SuseLin box I went into Yast > Network Devices > Network Card. There I chose to change my current network card and added additional IP addresses (e.g.,, etc.). Use an IP range that your router searches for. That baffled me for a while. You may have to check your router docs for more info.

    Login to ISPConfig and go to Management > Server > Settings. Add the new IP addresses to the IP List (e.g.,, etc.).

    Now go to ISP Manager. For the site that you want to access internally setup the domain with '' and IP Address is ''. Yes, use the extension .int (internal) or .loc... you can name the extension whatever you want. Thats the beauty of pointing to your internal DNS server, you can makeup your own extensions. Make sure you don't use a TLD extension (.com, .net, .info) because then you will override the live website because it will pickup your local website first.

    All the workstations that I set with Preferred DNS to the SuseLin (ISPConfig) box now look for before going to the www. When I type, it goes to my live website online.

    Hope this helps,


Share This Page