Details on problem /mailuser login and more (long)

Discussion in 'Installation/Configuration' started by linutzy, Sep 4, 2005.

  1. linutzy

    linutzy New Member

    What's Up with This? I deleted the (2) required dirs again and will now run a fresh install.

    I'm not mad or anything just a little lost as always.

    I am behind a linksys router and have a WAN static IP from my provider 216.X.X.X
    The linksys is the gateways with an ip of 192.168.1.x and the debain box with ISPconfig
    installed is behind it also on a 192.168.1.x address (these are also static LANS), able to get online ping IP's the whole works. The ports that need forwarding are doing so with no issues.

    I also have two registered domains fakedomaint.net and fakedomainp.ca
    I also have a primary name server glued by easydns.com using my static IP however after a new install nslookup cannot see it ns1.fakedomaint.net, however since easydns.com does secondary dns I'm able to load the page.



    I follow (no webalizer install) the steps located at falktotimme.com for the debian 3.1 setup.

    In the dir called admin I do the following.
    tar xvfz ISPConfig*.tar.gz
    cd install_ispconfig
    ./setup

    This part works great.


    I go through the certification process on the command line and in steps 7 & 8 I say no.


    I go through the "standard" setup saying yes to postfix and proftp.


    Please enter your MySQL server: localhost
    Please enter your MySQL user: etc etc

    .......then it goes to

    Please enter the IP address of the ISPConfig web: Do I add my WAN static IP from my provider or my router 192.168.1.x IP and if I make a mistake where do I change it?For the sake of this long question I put in my router assigned address 192.168.1.x, the same address I have in /etc/network/interfaces.
    (there is no second IP installed there)




    Please enter the host name (e.g. www):www
    Please enter the domain: fakedomaint.net
    I pick https and it says I have connected to MYSQL server, restarts postfix.
    I get the Congrats screen and it's ready for me to login to
    https://www.fakedomaint.net:81 I login change my password and am ready to "try" to make some sites.

    The actual tool is pretty fast I don't have to wait 30 to 60 seconds more like 5-10.


    My tree looks like this.

    admin
    Reseller
    Clients
    Sites
    Recycle Bin


    The first thing I do is click "New Client" since I want the basics first (Not New Reseller).

    Group: admin
    Title: Fakedomaint.net Client
    Folder: admin, Reseller, Clients, Sites (I leave it as admin)

    I fill out the information needed in Master Data.
    I then click SAVE for the purpose of explanation.


    The tree now looks like this:

    admin
    Reseller
    Clients
    Sites
    Recycle Bin
    fakedomaint.net Client

    I click "fakedomaint.net Client" in the tree so that I can click the "Site Management" tab.
    I click the New button

    Reseller: admin
    Customer: fakedomaint.net Client
    Hostingplan: Individual Settings
    NEXT>>>

    ISP SITE>>BASIS

    Group: admin
    Title: fakedomaint.net Site
    Folder: admin, Reseller, Clients, Sites (I leave it as admin again)
    Server: Server 1
    Hostname: www
    Domain: fakedomaint.net
    IP Address: 192.168.1.x
    Create DNS: CHECKED
    Space MB: -1
    Traffic MB: -1
    Traffic Exceedance: No Action
    Max. User: -1
    Max. Domain: -1

    Everything is checked from Shell Access to MAIL USER LOGIN for the purpose of testing.
    I click save again and now "Site Management" has an IP of 192.168.1.x listed. I click on
    that IP address then "USER and EMAIL" tab and begin to make an email account.

    NEW>>
    Real Name: my name
    Email: myname@fakedomaint.net
    Username: web1_myname
    Password: somepassword
    WebSpace MB: -1
    MailSpace MB: -1
    Administrator: CHECKED
    Shell Access: CHECKED

    Advanced Settings Tab I leave everything blank and unchecked.
    Spamfilter and Antivirus I leave everything blank and unchecked.

    I click "Save" and now in "USER and EMAIL" I see

    User Surname Email Admin CatchAll
    web1_myname my name myname 1 0


    NOTE: FOR some reason it had a co-domain listed with the same IP, I deleted that.

    I also click the "OPTIONS TAB" and mail server says "Local Mail Server"
    Logsize: 30%

    DirectoryIndex: index.html
    index.htm
    index.php
    index.php5
    index.php4
    index.php3
    index.shtml
    index.cgi

    The SSL tab is also blank just so you know.

    SIDE NOTES:

    Web-Server: Online
    FTP-Server: Online
    SMTP-Server: Online
    POP3-Server: Online
    BIND-Server: Online
    mySQL-Server: Online

    Web Server: On
    FTP Server: On
    SMTP Server: On
    DNS Server: On
    mySQL Server: On
    Firewall: Off

    MTA TYPE: POSTFIX
    MAILDIR: CHECKED





    Okay at this point I click the header
    Web-FTP

    "Web Selection" shows
    Select Web: fakedomaint.net Site (nothing else to pick in drop down)
    Username : web1_myname
    Password : some password

    I click selection and it logs me in and I see a number of folders.

    ssl
    log
    user
    cgi-bin
    web
    ftp
    phptmp


    Question #1 Great but now which folder do I create my first web page in and
    what is the URL PATH?
    Question #2 Still not able to login to https://www.fakedomaint.net:81/mailuser.

    If I missed something please tell me I'm trying as hard as I can with this stuff.
     
  2. domino

    domino New Member

    I think you still have a bit of reading up to do on virtual IP in Linux. Also try to bind all domains on a single IP and NOT use HTTPS unless you know what the considerations are when using SSL. It's a rule of thumb that you dedicate a domain to it's own IP if it requires SSL. So I think you need to solve the first problem, which is getting all your domains working, before you tackle the next problem. Otherwise you will loose you mind.
     
  3. linutzy

    linutzy New Member

    Yeah I think the https road might be a bit to much.

    I will try to do the http install as you have stated. You are right I have a bit more to do. But I really like ispconfig.

    When it comes down to it I need a walk through
    for creating domain1.net, health.domain1.net, math.domain1.net and domain2.ca for my friends each with seperate logins. I have a lot of DNS stuff to look at also and now for some reason after I reset the modem and baught a switch for other technical reasons I get the default page for my domain and not the apache page which is good but I don't know how I got it.

    But again the SSL input you provided will be looked at. If I lose my mind it means I'm just getting broken in to this Linux world.
     
  4. till

    till Super Moderator

    Hi,

    you have entered www.fakedomain.net as your server domain and then later created a virtual host www.fakedomain.net. This will not work, the hostname and domain of the server can not be the same than a hostname of a virtual website.

    To your 1. question. Create the webpages in the web folder.
     
  5. linutzy

    linutzy New Member

    Okay

    So I have fakedomain.com I just want to start with the one domain.
    1) what are the steps I should take so that I don't make a mess again?
    2) what IP should I use during the install (router private or WAN static)?

    I've read the docs now it seems I have done just about everything wrong.

    Oh well.
     
  6. domino

    domino New Member

    I can't speak much for Debian. But for Fedora, towards the end of the installation, it asked me what my domain and IP address of Linux. Remember the IP address you assigned for Linux.

    When you install ISPConfig, it will ask you again what the IP address is. Enter the IP address your assigned to Linux.
     
  7. domino

    domino New Member

    If you want to make your Linux webserver sean outside of your network, you need to "port forward" the requests to your linux box. You do this from your router. This has beed discussed several times throughout the forum. Please read you router manual to learn how to port forward to your linux server. :p
     
  8. linutzy

    linutzy New Member

    Done

    Port Forwarding has been done for the Linux box behind my linksys router. There is a control panel feature in the linksys router that allows me to do this or else I would not be able to load the site and have the outside world see it.
    I just wanted to know where my static wan ip might come into play.
     
  9. Phil

    Phil New Member

    Dual use of domain

    I have two new domains that I have purchased for this new server that I have just finished building.

    I have used one for the server domain and have used it again as a virtual website along with my second new domain name and they both appear to be working correctly. I can access all areas correctly and send and recieve emails log in to ftp create databases view website stats etc without any problems. I can still access all of the admin functions without any problems.

    Is this a bad thing?
    Should I rebuild the server and use 1 domain for server setup and the other as a virtual website?

    How I did it...

    1. I built the server using one of my new domain names.
    2. I installed ISPConfig using the same domain.
    3. I created a reseller.
    4. I created a client for that reseller.
    5. Selected site management for that client and added the two domains there with no problems.

    I thought that was the way to do it as it made sense to me but I am just confused now!

    Phil.
     
    Last edited: Feb 15, 2006
  10. till

    till Super Moderator


    If everything is working for you, you dont have to change anything. What might happen is, that if you enable an email catchall account in the website that has the same domain then your server, this email address will get all emails, even if there exist another account with that email address.
     
  11. Phil

    Phil New Member

    Till,

    Thanks for the quick response it is very much appreciated.

    I am pleased that I do not have to build the server again and I will make a note of the fact that I can not set a catchall for the main domain.

    Is there anything else that I should be aware of whilst using this dual use of domain setup?

    ISPConfig is very flexible. This only goes to confirm my choice of ISPConfig as a good product.

    Phil.
     
  12. till

    till Super Moderator

    No, i dont think so.
     

Share This Page