Deprecated notice keep show up...

Discussion in 'General' started by n3m0, Oct 9, 2016.

  1. n3m0

    n3m0 New Member

    Dear All,
    I got problem with my fresh installation of ISPConfig 3. Everything went smoothly, but then I got this deprecated errors show at the website. For example:
    Deprecated: Non-static method JSite::getMenu() should not be called statically in /var/www/clients/client1/web1/web/templates/gk_news/lib/framework/helper.layout.php on line 177

    My server spec:
    - Ubuntu
    - Apache 2
    - Latest ISPconfig stable release.

    My steps:
    1. I have googling for hours, but none can fix my problem...
    2. follow no luck...
    3. Put error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT in
    - /etc/php/7.0/fpm/php.ini
    - /etc/php/7.0/apache2/php.ini
    - /etc/php/7.0/cgi/php.ini
    - /etc/php/7.0/cli/php.ini
    4. I also put php option in client's website via ispconfig panel.
    5. I set PHP Options at template's client in ISPconfig to disable, and check mark on CGI available.
    6. put in .htaccess
    php_value display_errors 1
    php_value display_startup_errors 1
    7. put in index.php the value:
    error_reporting(E_ALL &~ E_NOTICE &~ E_DEPRECATED);

    Resync and Restart apache2 every time i made a change and tried to reboot too. But no luck.. the notice still show up on the website. Anyone could lead me what I miss?? :(

    I do really appreciate it...
    Thank you,
  2. n3m0

    n3m0 New Member

    Finally i can solve it.. by putting:


    in certain main .php file.


Share This Page