Dependency update problem with certbot

Discussion in 'ISPConfig 3 Priority Support' started by Petar, Jan 23, 2017.

  1. Petar

    Petar New Member

    Dear Sirs,
    I have a problem with upgrading on all of the Debian Jessie servers that i have.
    They were installed following:
    The Perfect Server - Debian 8.4 Jessie (Apache2, BIND, Dovecot, ISPConfig 3.1)

    If i do apt-get update+upgrade, this are not upgraded or installed:
    certbot python-acme python-certbot python-certbot-apache

    Because of that in ISPConfig Monitor 3.1 i get:
    Warning
    One or more components needs an update
    -----------------------------------------------------
    Inst python-dnspython (1.12.0-1 Debian:8.7/stable [all])
    Inst python-certbot-apache [0.8.1-1~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all]) []
    Inst certbot [0.8.1-2~bpo8+1] (0.9.3-1~bpo8+2 Debian Backports:jessie-backports [all]) []
    Inst python-certbot [0.8.1-2~bpo8+1] (0.9.3-1~bpo8+2 Debian Backports:jessie-backports [all]) []
    Inst python-acme [0.8.1-1~bpo8+1] (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf python-dnspython (1.12.0-1 Debian:8.7/stable [all])
    Conf python-acme (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    Conf python-certbot (0.9.3-1~bpo8+2 Debian Backports:jessie-backports [all])
    Conf certbot (0.9.3-1~bpo8+2 Debian Backports:jessie-backports [all])
    Conf python-certbot-apache (0.9.3-1~bpo8+1 Debian Backports:jessie-backports [all])
    ----------------------------------------------------
    Should i do the upgrade with this?
    apt-get -t jessie-backports install certbot python-acme python-certbot python-certbot-apache

    Many thanks for the support
     
  2. sjau

    sjau Local Meanie Moderator

    That howto in step 11 says to download certbot from the EFF website.
     
  3. Petar

    Petar New Member

    I followed the instructions during the installation before several months.
    After that it was all setup and working fine in the ISPConfig 3.1 installation.
    This problem occurred with the upgrades during December-January when it kept saying:
    The following packages have been kept back: certbot python-acme python-certbot python-certbot-apache
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I would try to install the kept-back packages.
     
  5. Petar

    Petar New Member

    Hi Till, thank you for your answer, do you mean thru backports like this:
    apt-get -t jessie-backports install certbot python-acme python-certbot python-certbot-apache
    Should i also make some settings afterwards or everything will be unchanged for the ISPconfig?
     

Share This Page