deleting site using remote user

Discussion in 'General' started by gauthier, Mar 22, 2008.

  1. gauthier

    gauthier New Member

    Hi, I am newbie.

    I have script that successfuly uses the remote user tool to create sites such as "createdsite.mymainsite.com"

    Now I am trying to delete "createdsite.mymainsite.com" using:

    No error is returned, but site is not deleted: It is still in the site list of ISPconfig. If I try to create it newly using my script, web_id is zero. (web_id = $soapclient->call('service',$params)).

    Recycle bin is empty but there is a forever note: "Items remaining in recycle bin after emptying are currently in update state. Please try to delete them later"...

    ispconfig.log does not show anything related with site deleting as far as I understand it.

    I would be gratefull if someone can help me.

    Moreover I would like to know what would be deleted excatly by the "web_delete". Does this function also delete databases and files ?

    Thanks for all.
     
    Last edited: Mar 22, 2008
  2. rduval

    rduval New Member

    I'm having a similar problem deleting sites.

    I downloaded the prebuilt VM from VMWare. It's using 2.2.3. Everythings been ok for the 5 or 6 domains I've transfered to this machine but the last one seems to be having problems (maybe a redirection problem) so I deleted it (from the mail login on port 81) and figured I'd make another and start again.

    It says it's gone (not in the list of sites anymore) but when I try to make a new site with the same name it says there's already one on the system with that name. I looked in the DNS and the record was still there so I deleted it too but still it won't let me create the site?

    Any ideas, also anybody know why I have 2.2.3 when it doesn't seem to even be released???
     
    Last edited: Mar 23, 2008
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Version 2.2.3 has been released long time ago. I guess you mix up 2.2.3 with 2.3.2. The vmware image from vmware is completely outdated.

    To your original problem (which is not related to the remoting interface as 2.2.3 does not have a remoting interface), please empty the recycle bin's.
     
  4. rduval

    rduval New Member

    Thanks Till, I'll try emptying the trash when I get to work...

    On the version thing (I'm assuming ispconfig.org is the proper website) it says "2008-02-12 - ISPConfig 2.2.21 released". and it confirms that on the downloads webpage. Isn't that the latest?

    If the VMWare image show 2.2.3 under the ISPCOnfig help menu how is it outdated? I'm confused?

    If it is outdated is 2.2.21 the latest?
     
  5. gauthier

    gauthier New Member

    Hi,

    I am using last version. This is 2.2.21

    Deleting sites using the control panel on port 81 is ok, this is not the question.

    The problem comes using REMOTE USER. I mean, using a PHP script with " $soapclient->call('service',$params); "

    It seems the remote user cannot delete sites (as far as I am doing it rightly).

    Also, it seems remote user cannot create database on created site but this is not a problem because I can create globals databases using the "CREATE DATABSE" mysql query. (I tried to create databases using remote user: no error, but no database created)

    Thanks.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    @rduval: 2.2.3 < 2.2.21 or in words 2.2.3 is 18 versions older then 2.2.21.

    @gauthier: The remote user can delete sites, but it can not empty the recycle bin in the current version of the remoting API.
     
  7. rduval

    rduval New Member

    Ok, gotcha. Didn't look at it that way. Guess I assumed the "21" was really "2.1".

    Can I just run the 2.2.21 install over the 2.2.3? Will it be happy (if you know)?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    It might work, but I did not test it.

    In any case, run this command before you update:

    apt-get install cpp g++
     
  9. rduval

    rduval New Member

    Coiuple of quesitons...

    Does it automatically know where to install itself or will it install in the dir where I run the install?

    How would I know which dir the old one was installed in?

    IF everything is done right shouild it be a live new version or does it have to be "rebuilt" like it's a fresh install?

    Thhanks
     
  10. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig knows where to install itself. It is installed in /root/ispconfig (backend) and /home/admispconfig (frontend).

    How do you mean that?
     

Share This Page