Delete function

Discussion in 'Feature Requests' started by Qrup, May 3, 2006.

  1. Qrup

    Qrup New Member


    I'd like to request the delete function to be fixed.
    I found out that deleted users still were in the "users" file under "/home/admispconfig/ispconfig". When I deleted the name that "Already were in the system" I was able to create a user with that name again.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How shall ISPConfig "know" that you manually removed a user that was created before you installed ISPConfig? I think scanning the /etc/passwd file periodically for the rare case you deleted a user manually is not a good idea.
  3. oliver.blaha

    oliver.blaha ISPConfig Developer ISPConfig Developer

    Hm, Till, I didn't read anything about manually here ;)
    I guess he just didn't find the recycle bin :D

    Deleted users are not really deleted, but moved to the recycle bin. Just empty it and the user will be really gone.
  4. Qrup

    Qrup New Member

    No. Sorry if I did not make my self understandable. What I did was:

    1) Create a client (user)
    2) Delete the user (in ISPConfig)
    3) Empty the recycle bin (No.. I'm not stupid Oliver.. sorry to dissapoint you)
    4) Try to create a user with the same username

    I was then told that the user already existed in the system. In my opinion then the user should be totally deleted.

    5) I then went to "/home/admispconfig/ispconfig" where I deleted the username. I was now able to create a user with that name in the ISPConfig system again.

    Maby I got in this situation by having a unix user with the same same also, but I'm not sure (still kinda' noobish).
  5. falko

    falko Super Moderator ISPConfig Developer

  6. Qrup

    Qrup New Member


    Hi Falko,

    That was exactly the problem I also had. I found the 'users' file and deleted the unwanted username.. hoping that I didn't mess things up.

    Is this not an error? I mean, if an admin wants to use that name and there is no ISPConfig client using the name, should it not be possible to 'hijack' the name? I know that redundant names is a no-go, but if it is not used...?

    Anyway.. thanks for a really good system and good support :)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not an error at all. It is a nescessary security faeture.

    Think of the following scenario.

    1) You disabled user prefixes.
    2) One of your users adds an email user with the username "root". This overwrites your current root user and now the customer owns your server.
  8. Qrup

    Qrup New Member

    U'r right

    Ofcourse. I was not thinking about the users that was not in the ISPConfig system.
    That was also why I had the unwanted username in the 'users' file.. I created it as an admin account in the Debian system. Then I tried to create the same user in ISPConfig. I could not do that, so I deleted the admin account and recreated it with another name. I then tried to create the user in ISPConfig, but now the name was in the list. Most unfortunate, but I can see that my "solution" cannot be used because of security reasons like you say Till.

    Thanks for a great setup :)

Share This Page