Delete files from /lib/modules?

Discussion in 'Technical' started by stackahumanoid, Oct 23, 2008.

  1. stackahumanoid

    stackahumanoid New Member

    Hey,

    I'm trying to run some kernel updates on a redhat enterprise server but get the following error...

    Fetching Obsoletes list for channel: rhel-i386-es-4...
    ########################################

    Fetching rpm headers...
    ########################################

    Name Version Rel
    ----------------------------------------------------------
    ed 0.2 36.el4_7.1 i386
    kernel 2.6.9 78.0.5.EL i686
    kernel-devel 2.6.9 78.0.5.EL i686
    kernel-hugemem-devel 2.6.9 78.0.5.EL i686
    kernel-smp 2.6.9 78.0.5.EL i686
    kernel-smp-devel 2.6.9 78.0.5.EL i686
    kernel-utils 2.4 14.1.117 i386
    sos 1.7 6.6.el4 noarch


    Testing package set / solving RPM inter-dependencies...
    ########################################
    RPM package conflict error. The message was:
    Test install failed because of package conflicts:
    installing package kernel-smp-2.6.9-78.0.5.EL needs 26MB on the / filesystem
    installing package kernel-smp-devel-2.6.9-78.0.5.EL needs 26MB on the / filesystem
    installing package kernel-utils-2.4-14.1.117 needs 27MB on the / filesystem

    there isn't much space in / but there's 313mb in /lib/modules....which contains the following

    2.6.9-34.0.1.EL
    2.6.9-34.0.2.ELhugemem
    2.6.9-42.0.2.ELsmp
    2.6.9-42.0.8.EL
    2.6.9-5.ELhugemem
    2.6.9-34.0.1.ELhugemem
    2.6.9-34.0.2.ELsmp
    2.6.9-42.0.3.EL
    2.6.9-42.0.8.ELhugemem
    2.6.9-5.ELsmp
    2.6.9-34.0.1.ELsmp
    2.6.9-42.0.2.EL
    2.6.9-42.0.3.ELhugemem
    2.6.9-42.0.8.ELsmp
    kabi-4.0-0
    2.6.9-34.0.2.EL
    2.6.9-42.0.2.ELhugemem
    2.6.9-42.0.3.ELsmp
    2.6.9-5.EL
    kabi-4.0-0smp

    Can I safely delete/move some files from this directory to free up some space?

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    df -h
    ?
     

Share This Page