DegradedArray event on /dev/md0 and md1

Discussion in 'Server Operation' started by ColdDoT, Sep 30, 2006.

  1. ColdDoT

    ColdDoT Member

    Hello sometimes i get this kind of mail
    Code:
    This is an automatically generated mail message from mdadm
    running on server
    
    A DegradedArray event had been detected on md device /dev/md0.
    
    Faithfully yours, etc.
    
    P.S. The /proc/mdstat file currently contains the following:
    
    Personalities : [raid1] 
    read_ahead 1024 sectors
    md0 : active raid1 ide/host1/bus0/target0/lun0/part4[0]
          67633536 blocks [2/1] [U_]
          
    md1 : active raid1 ide/host1/bus1/target0/lun0/part2[0]
          76172096 blocks [2/1] [U_]
          
    unused devices: <none>
    and this 1

    Code:
    This is an automatically generated mail message from mdadm
    running on server
    
    A DegradedArray event had been detected on md device /dev/md1.
    
    Faithfully yours, etc.
    
    P.S. The /proc/mdstat file currently contains the following:
    
    Personalities : [raid1] 
    read_ahead 1024 sectors
    md0 : active raid1 ide/host1/bus0/target0/lun0/part4[0]
          67633536 blocks [2/1] [U_]
          
    md1 : active raid1 ide/host1/bus1/target0/lun0/part2[0]
          76172096 blocks [2/1] [U_]
          
    unused devices: <none>
    Does some 1 know how i can fix it?
    and i get every day i get this mail
    Code:
    /etc/cron.daily/man-db:
    mandb: warning: /usr/share/man/man1/f77.1.gz is a dangling symlink
    mandb: warning: /usr/share/man/man1/rmiregistry.1.gz is a dangling symlink
    /etc/cron.daily/mysql-server:
    /etc/cron.daily/mysql-server: line 27: KEEP_BINARY_LOGS: unbound variable
    run-parts: /etc/cron.daily/mysql-server exited with return code 1
    /etc/cron.daily/sysklogd:
    start-stop-daemon: unrecognized option `--quiet--signal'
    Try `start-stop-daemon --help' for more information.
    /etc/cron.daily/tmpreaper:
    Please read /usr/share/doc/tmpreaper/README.security.gz first;
    edit /etc/tmpreaper.conf to remove this message.
    i have already tryed to solve it but i can't fix it

    greets ColdDoT
    OS:debian sarge
    Mysql: trough packed manager
    Raid: 2 hd disk of the same size

    BTW
    i've got a mysql DB from packeges but the name is
    MySQL - 5.0.24a-Debian_5-log
    is there a way to change it back to MySQL 5.0.24a
     
    Last edited: Sep 30, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Is it possible that one of your hard disks is broken? Because the output of
    Code:
    cat/proc/mdstat
    should be similar to this one:

    Code:
    Personalities : [raid1]
    md0 : active raid1 sda1[0] sdb1[1]
          497856 blocks [[B][COLOR="Red"]2/2[/COLOR][/B]] [UU]
    
    md1 : active raid1 sda3[0] sdb3[1]
          154794240 blocks [[B][COLOR="Red"]2/2[/COLOR][/B]] [UU]
    
    unused devices: <none>
     
  3. ColdDoT

    ColdDoT Member

    Thats higly unlikly because it is verry new server.
    i have upgraded verry often software and it can be that i did something wrong with the raid things
     
  4. falko

    falko Super Moderator ISPConfig Developer

Share This Page