default page only

Discussion in 'Installation/Configuration' started by FredZ, Mar 21, 2018.

  1. FredZ

    FredZ Member HowtoForge Supporter

    Hello all

    Very new to ispconfig.

    Have install ispconfig3 on debian stretch as per the tutorial.

    Have setup a website as per the tutorial.

    I have installed an alternate default page (index.html) by replacing the default in the web folder. But the new page I have installed isn't being displayed. The default page only is being displayed.

    I've spent a day on it and can't for the life of me work out what I have done wrong.

    Any help would be most appreciated.

    Regards

    Fred
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What file have you replaced? My experience is that the index.html in the web/ folder of the website is displayed, and if I edit the file the edited version gets displayd. If this does not work in your setup, I would check the url written in browser address bar really goes to that server.
    In your workstation where you run the browser, edit hosts file and add line for the website FQDN and the IP address of your ISPConfig server. This should assure the url takes you to the correct server.
    https://en.wikipedia.org/wiki/Hosts_(file)
     
    ahrasis likes this.
  3. FredZ

    FredZ Member HowtoForge Supporter

    OK, so is seems I am having this issue again. But in fareness, I haven't had to create a new site in a very long time. My setup is farely set and forget as I'm only hosting my own websites (no DNS)

    I have created a new site.
    I deleted the default files in the root (web folder).
    I uploaded my site (a php site) to the web folder.
    But I only get the default placeholder page (index.html) when I navigate to the site.

    I'm sure I am missing something basic but I can't see the wood for the trees.

    ISPConfig Version: 3.1.13
    I used this for the original install

    Regards

    Fred
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you have many websites in ISPConfig, check that each website has in IP Address field * or the IP-number. All websites must have the same, do not mix the two.
    To test further, create a website that is sure to be the first in alphabetic order, name it for example 0000aaaa.site (it does not have to exist in name service). Put some index.html that is different from the others so you know if you end up in this new site. If you end up here, the web server is suffering from something and you should look at logs and settings files to see why it can not serve the correct website from the URL.
    You wrote you used this https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/ for initial install. But that is the multiple PHP versions tutorial. How have you installed the OS and ISPConfig? And what web server are you using?
     
  5. FredZ

    FredZ Member HowtoForge Supporter

    After some significant searching I finally worked out what I had done wrong.
    Whilst I was setting up the FTP account for the website I failed to select the correct website in the FTP configuration. Fortunately the website I uploaded everything to was a redirected site and didn't affect anything else.
    It just goes to show that you should read everything and check things instead of rushing and presuming.

    Many thanks for your input.

    Regards

    Fred
     
    till likes this.

Share This Page