debian upgrade broken.. apt-get stuck

Discussion in 'Installation/Configuration' started by guthrie, Mar 30, 2009.

  1. guthrie

    guthrie New Member

    I am trying to upgrade my Debian system to current stable release.
    I tried a simple (simplistic?!) apt-get upgrade, but apparently my system was out of date enough that it failed to do a two release upgrade.
    So I found:
    http://www.howtoforge.com/how-to-upgrade-a-debian-etch-system-server-and-desktop-to-debian-lenny

    and tried to do that, but it is also failing. I reverted wo what I think is a stable etch install, but can't get the next step to stable (==lenny) to work.

    All details below, any hints appreciated!

    Right now: /etc/version = 4.0, uname-a -> kernel is 2.6.3
    ==================================================
    alpha:/usr/X11R6/bin# apt-get update
    ...
    Fetched 3B in 0s (3B/s)
    Reading package lists... Done

    alpha:/usr/X11R6/bin# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    The following packages have been kept back:
    ...
    349 upgraded, 0 newly installed, 0 to remove and 128 not upgraded.
    Need to get 0B/166MB of archives.
    After unpacking 60.8MB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 57982 files and directories currently installed.)
    Preparing to replace libc6 2.3.6.ds1-13etch9+b1 (using .../archives/libc6_2.7-18_i386.deb) ...
    Checking for services that may need to be restarted...
    Checking init scripts...
    WARNING: POSIX threads library NPTL requires kernel version
    2.6.8 or later. If you use a kernel 2.4, please upgrade it
    before installing glibc.

    The installation of a 2.6 kernel _could_ ask you to install a new libc
    first, this is NOT a bug, and should *NOT* be reported. In that case,
    please add etch sources to your /etc/apt/sources.list and run:
    apt-get install -t etch linux-image-2.6
    Then reboot into this new kernel, and proceed with your upgrade
    dpkg: error processing /var/cache/apt/archives/libc6_2.7-18_i386.deb (--unpack):
    subprocess pre-installation script returned error exit status 1
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.7-18_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    alpha:/usr/X11R6/bin# apt-get install -t etch linux-image-2.6
    Reading package lists... Done
    Building dependency tree... Done
    Package linux-image-2.6 is a virtual package provided by:
    linux-image-2.6.26-1-xen-686 2.6.26-13lenny2
    linux-image-2.6.26-1-vserver-686-bigmem 2.6.26-13lenny2
    linux-image-2.6.26-1-vserver-686 2.6.26-13lenny2
    linux-image-2.6.26-1-openvz-686 2.6.26-13lenny2
    linux-image-2.6.26-1-amd64 2.6.26-13lenny2
    linux-image-2.6.26-1-686-bigmem 2.6.26-13lenny2
    linux-image-2.6.26-1-686 2.6.26-13lenny2
    linux-image-2.6.26-1-486 2.6.26-13lenny2
    You should explicitly select one to install.
    E: Package linux-image-2.6 has no installation candidate

    alpha:/usr/X11R6/bin# apt-get install -f linux-image-2.6.26-1-486 2.6.26-13lenny2
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package 2.6.26-13lenny2

    alpha:/usr/X11R6/bin# apt-get install -f linux-image-2.6.26-1-486
    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
    initramfs-tools libc6 libselinux1 libvolume-id0 udev
    Suggested packages:
    locales glibc-doc libc6-i686 linux-doc-2.6.26
    Recommended packages:
    busybox busybox-initramfs
    The following NEW packages will be installed:
    initramfs-tools libvolume-id0 linux-image-2.6.26-1-486 udev
    The following packages will be upgraded:
    libc6 libselinux1
    2 upgraded, 4 newly installed, 0 to remove and 475 not upgraded.
    Need to get 20.6MB/25.1MB of archives.
    After unpacking 60.6MB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Get:1 http://ftp.us.debian.org stable/main libvolume-id0 0.125-7 [76.1kB]
    Get:2 http://security.debian.org stable/updates/main linux-image-2.6.26-1-486 2.6.26-13lenny2 [20.2MB]
    Get:3 http://ftp.us.debian.org stable/main udev 0.125-7 [253kB]
    Get:4 http://ftp.us.debian.org stable/main initramfs-tools 0.92o [75.3kB]
    Fetched 20.6MB in 54s (378kB/s)
    Preconfiguring packages ...
    (Reading database ... 57982 files and directories currently installed.)
    Preparing to replace libc6 2.3.6.ds1-13etch9+b1 (using .../archives/libc6_2.7-18_i386.deb) ...
    Checking for services that may need to be restarted...
    Checking init scripts...
    WARNING: POSIX threads library NPTL requires kernel version
    2.6.8 or later. If you use a kernel 2.4, please upgrade it
    before installing glibc.

    The installation of a 2.6 kernel _could_ ask you to install a new libc
    first, this is NOT a bug, and should *NOT* be reported. In that case,
    please add etch sources to your /etc/apt/sources.list and run:
    apt-get install -t etch linux-image-2.6
    Then reboot into this new kernel, and proceed with your upgrade
    dpkg: error processing /var/cache/apt/archives/libc6_2.7-18_i386.deb (--unpack):
    subprocess pre-installation script returned error exit status 1
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.7-18_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    alpha:/usr/bin# cat /etc/*version*
    4.0
    alpha:/usr/bin# uname -a
    Linux alpha 2.6.3-1-386 #2 Tue Feb 24 20:20:23 EST 2004 i686 GNU/Linux


    /var/log/dpkg.log:: (many of these!)
    2009-03-29 08:27:34 upgrade libc6 2.3.6.ds1-13etch9+b1 2.7-18
    2009-03-29 08:27:34 status half-configured libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:34 status unpacked libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:34 status half-installed libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:41 status unpacked libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:43 status installed libc6 2.3.6.ds1-13etch9+b1
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  3. guthrie

    guthrie New Member

    apt-upgrade failing..

    Well,
    1) the problem is that dist-upgrade fails. and more specifically even if I just convert apt sources to stable (from etch), apt-fails - can't upgrade, or even do anything - it is in a stuck state.

    Errors all shown above - main thing seems to be a lack of ability to get libc6.
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.7-18_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    /var/log/dpkg.log:: (many of these!)
    2009-03-29 08:27:34 upgrade libc6 2.3.6.ds1-13etch9+b1 2.7-18
    2009-03-29 08:27:34 status half-configured libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:34 status unpacked libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:34 status half-installed libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:41 status unpacked libc6 2.3.6.ds1-13etch9+b1
    2009-03-29 08:27:43 status installed libc6 2.3.6.ds1-13etch9+b1

    2) Where'd I get the old kernel? Hmm, from apt! :)
    I hadn't upgraded this system in awhile, it was stable, and just running along.

    If my kernel is old, why does apt-update not want to update it?
     
    Last edited: Mar 30, 2009
  4. guthrie

    guthrie New Member

Share This Page