Debian stretch Pureftp + newer MariaDB fixes

Discussion in 'Tips/Tricks/Mods' started by ztk.me, Jul 16, 2018.

  1. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    Howto setup newer Mariadb is covered here:
    https://www.howtoforge.com/community/threads/debian-9-install-mariadb-10-3.79531/

    If you install newer MariaDB-Server on your stretch box because the new features are overwhelming... keep in mind that if you need
    PureFtp with mysql-extension ( like ISPConfig needs ) there has been a change in the libraries ( long story exists ) which are not backported to old Debian release...

    Error is like
    you need to recompile PureFtp against the new library to get full support for mariadb:
    Code:
    apt-get install devscripts
    mkdir /usr/src/pure-ftpd
    cd /usr/src/pure-ftpd
    apt-get source pure-ftpd
    apt-get build-dep pure-ftpd
    cd pure-ftpd-1.0.43/
    
    now edit the changelog, or else apt will update to the "previous" version. Use
    Code:
    dch -i
    
    It could look like:
    Code:
    dpkg-buildpackage -uc -b
    cd ..
    dpkg -i pure-ftpd-mysql_1.0.43-3.1_amd64.deb pure-ftpd-common_1.0.43-3.1_all.deb
    systemctl restart pure-ftpd-mysql.service
    
    And it starts again :)

    it should not touch the settings in /etc/default/pure-ftpd-common
     
    Last edited: Jul 18, 2018
    Messi89 and till like this.
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    *editbump: need devscripts, bump version so apt won't bug you with outstanding update, keep an eye on your versions
     
  3. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

  4. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    you forgot to run
    Code:
    mysql_upgrade
    service mysql restart
    
     

Share This Page