Debian Squeeze, Squid, Kerberos/LDAP Authentication, Active Directory Integration

Discussion in 'HOWTO-Related Questions' started by andyrogers, Jul 15, 2011.

  1. andyrogers

    andyrogers New Member


    I have been following the excellent guide for Squid on Debian Using AD .

    So far this is working very, very well. However I have seem to come a bit unstuck when it comes to using Windows7 machines. When we try to connect a windows 7 machine using Detect Auto Proxy, we keep getting asked for User Name & Password. It seems that the user's AD Username & Password are not being passed through to Squid Server, or it is being blocked by Windows some how.

    We have no problems at all with Windows7 machines.

    Is thier something missing from this How-To about Windows 7 that needs adding? Do any Windows 7 security settings need altering?
    The How to does not say about expecting issues with regards Win7, as it says it should work.

    Any help/suggestions would really be appreciated.


  2. octaviomaiden

    octaviomaiden New Member


    Do you solve your issue? im trying to that configuration but Im stuck in with this rule:
    external_acl_type internet_users %LOGIN /usr/lib/squid3/squid_ldap_group -R -K \
    -b "dc=example,dc=local" \
    -D [email protected] \
    -w "squidpass" \
    -f "(&(objectclass=person)(sAMAccountName=%v)(memberof=cn=Internet Users,ou=Security Groups,ou=MyBusiness,dc=example,dc=local))" \
    -h domaincontroller1.example.local
    (I replace the parameters of course)

    The squid doesn't start with that line, seems like the syntax is not right

Share This Page