[Debian Sarge] Installing A Bind9 Master/Slave DNS System Configuration Help

Discussion in 'Installation/Configuration' started by sethtat, Jan 16, 2007.

  1. sethtat

    sethtat New Member

    AM VERY NEW TO LINUX AND BIND

    I have setup two debian boxes using the The Perfect Setup - Debian Sarge (3.1)

    on both and then used the master/slave setup. I am getting an error when is restart the bind services on both servers

    the error is "Stopping domain name service: namedrndc: connect failed: connection refused"
    and then it tries to start the services and gives no error


    I have attached my two named.conf files from the master and slave.

    These are the last part of the files that I changed.

    Please help me get this up and running

    domain - friendswd.net
    master 72.16.90.178
    slave 72.16.90.179

    the master is my web and email server also

    i am going to install a hosting controll panel. I have been using ravencore

    It seems to work

    If anyone has any suggestions on which one to use please let me know
     

    Attached Files:

  2. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    You made a mistake somewhere in you DNS setup:
    Code:
    ;; ANSWER SECTION:
    friendswd.net.          10800   IN      A       82.165.133.52
    
    
    Code:
    ;; ANSWER SECTION:
    178.90.16.72.in-addr.arpa. 86392 IN     PTR     h178.90.16.72.ip.alltel.net.
    
    The domain and IP do not point to each other.
     
  3. sethtat

    sethtat New Member

    I do not even have the registar pointing to my dns server's yet
    I am trying to get them working first without errors.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I think it's a permissions problem, as some people pointed out in the comments below http://www.howtoforge.com/howto_bind_chroot_debian .
     

Share This Page