Debian Sarge + Ebox: DHCP, File, Print and Timeserver for Small/Medium Enterprises

Discussion in 'HOWTO-Related Questions' started by csarlee, Jan 23, 2007.

  1. csarlee

    csarlee New Member

    Hello All!

    Having a weird dependency problem with the tuto mentioned above:
    I tried to follow it and installed Debian Sarge 3.1 r4 on my server. When I tried to install E-box and its extras apt gave an error: slapd was not going to be installed. Ok, then I added slapd to the list but after it had problem with the version of slapd: one of the E-box components requires slapd 2.30.xx but only 2.2x.xx version can be installed due to the stable version. If I dist-upgrade to the testing version there is another dependency problem with E-box software component... :confused: :confused: :confused:

    So, what can I do? Could anybody help?

    Thanx in advance
  2. falko

    falko Super Moderator ISPConfig Developer

    Is it possible you modified /etc/apt/sources.list multiple times and therefore messed up your apt database?
  3. csarlee

    csarlee New Member

    Hi Falko!

    Hopefully, not. I ran apt-get update every time after I changed repos. Tonight I will reinstall the base system and retry it.

  4. sammi

    sammi New Member

    How do I open a web browser?

    Hi All

    This is also my first post to ths forum as I am new to "HowToForge" and new to the world of linux based servers.


    If these are a stupid questions then please let me know (gently) !

    I have so far followed the howto on I used the ebox installer iso image from I got to 3 Logging In To eBox where i have to open a web browser. When entering the bash command firefox. I get an error?

    How do I open a web browser?
  5. csarlee

    csarlee New Member

    Hello !

    I think you misunderstood something because eBox is a web-based stuff, so you can manage it from another PC with a web browser like Firefox. That tutorial does not cover installing X Window system which is the graphical user interface. So, because you don't have graphical interface, you can not use Firefox on that machine. Anyway, it would not be a wise thing to have X Window on a server due to security and resource related issues...
    By the way, could you follow the tutorial? I mean, you didn't have any problem during the installation...

  6. sammi

    sammi New Member

    Thanks for the quick reply! Still can't get it to work?

    Thanks for the quick response.

    I did initially have a problem with specific dependency files. Then I downloaded a copy of 'ebox installer.iso' from That worked straight out of the box until I got to open a web browser. :(

    My configuration:

    I have installed the ebox-installer.iso from as a vmware image. How do I access the web based interface.

    I tried:

    enabling my wired lan (On another PC) but I was getting an Automatic Private Address

    I tried configuring a static lan ip
    IP Address:
    Defualt gateway:

    Then I tried the following in a web browser:

    My VMWARE network adaptor VMnet1 is assigned by DHCP:
    My VMWARE network adaptor VMnet8 is assigned by DHCP:
    Last edited: Feb 5, 2007
  7. csarlee

    csarlee New Member


    I guess you should try your VMWARE IP addresses but I'm not very familiar with VMWARE things...

  8. sammi

    sammi New Member

    Thanks again,

    Their is something I need help with. I have installed a fresh copy of debian. I followed the tutorial on Running A File-, Print-, Proxy-, DHCP-, AND Time-Server For Small/Medium Enterprises I got the following dependency errors when installing ebox:

    The following packages have unmet dependencies:
    ebox-software: Depends: esofttool (>= 0.2) but it is not going to be installed
    E: Broken packages

    How do I install esofttool
  9. minimee

    minimee New Member

    I have just finished installed my debian machine and got this error, i followed the steppes in the tutorial by heart and i still got this error message. Is there any way of reapairing the harm that i might have done... i mean install by hand spald or something like that.

    The following packages have unmet dependencies:
      ebox-dns-cache: Depends: bind9 but it is not going to be installed
    E: Broken packages
    Last edited: Feb 6, 2007
  10. csarlee

    csarlee New Member

    Hi All!

    @ Mike
    Your problem seems very simple... You have not installed bind9 which is required.
    But did you have any problem with slapd (I think this is what you wanted to write)? Installed by hand?! Check my first post, this was the original problem I started this thread...
    I think we need someone who has been able to finish this tuto to give us some help.
    I will try it again on weekend and post result...
    @ sammi

    It will lead you to the same situation as I had and started this. When you try to install esofttool it requires slapd but higher than version 2.2x which is the available in the stable Debian...

    So I think all of us need some help...

  11. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
  12. falko

    falko Super Moderator ISPConfig Developer

    Did you mix different repositories in /etc/apt/sources.list?

Share This Page