Debian Sarge, Apache2 & Proxy Configuration

Discussion in 'Installation/Configuration' started by savkar, Mar 14, 2006.

  1. savkar

    savkar New Member


    I have a local server running as an email server behind a firewall and already use port 80 to connect to my separate box running a web server. I have a web interface for my local email that I wanted to make accessible externally, and instead of switching to different ports I wanted to try to use the proxy method in Apache.

    On my web server, which is running Debian Sarge and Apache2 (set up with the Perfect Setup description for Debian Sarge), I thought I could simply create a link from mods-available in /etc/apache2 to mods-enabled for proxy.load and proxy.conf.

    I then also went to my sites-available section and added a new available site (virtual host) as follows:

    <VirtualHost *>
    ProxyRequests Off
    ProxyPass /
    ProxyPassReverse /

    However, when I then restart apache and try to access the site, I get the following error in firefox and mozilla:

    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    NOW NOTE, I also went to /etc/apache2/mods-enabled and made a soft link to proxy.load and proxy.conf. I then edited proxy.conf so that the lines starting:

    ProxyRequests Off

    <Proxy *>
    Order deny,allow
    Deny from all
    Allow from .your.domain-name

    and changed the "Allow" to "Allow from

    What is going wrong here? I still get the forbidden error which is driving me crazy. Something obviously not configured right.
  2. savkar

    savkar New Member

    One more tid bit

    When I change "Allow from" to "Allow from all", this then all works. I am sure that is just not a good idea so I have turned this back off.

    I simply want to proxy pages from my internal server at I htought just stating allow from woudl do it, but apparently not.

  3. falko

    falko Super Moderator ISPConfig Developer

    Please try to use the IP address in the Allow line.
  4. savkar

    savkar New Member

    Using IP address didn't make a difference

    Tried my IP address for the internal server, but made no difference. I went back and as soon as I allow from all, then it works again.

    Very strange.
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you use the IP address you see when you run
  6. savkar

    savkar New Member

    Yes, that is, I use the IP address I statically have the internal server set to. But I will check again. Should have worked though...

Share This Page