Debian Lenny with VMware Server

Discussion in 'Installation/Configuration' started by fed, Jun 23, 2009.

  1. fed

    fed New Member

    Hi all,

    I'm having troubles installing VMware Server 2.0.1 on a Debian Lenny with Kernel 2.6.26-2-686-bigmem.

    I could successfully download vmware and start the install script.

    When running vmware-config.pl a message shows up that no pre-built *** modules where found for VMware Server and it has to build the modules.

    Code:
    Using compiler "/usr/bin/gcc-4.1". Use environment variable CC to override.
    
    What is the location of the directory of C header files that match your running
    kernel? [/lib/modules/2.6.26-2-686-bigmem/build/include]
    
    I'm using gcc-4.1 and also the header files are in /lib/modules/2.6.26-2.686.
    Building vmmon, vmci works just fine. While building vsock I get the following error message:

    Code:
    Building the vsock module.
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config5/vsock-only'
    make -C /lib/modules/2.6.26-2-686-bigmem/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.26-2-686-bigmem'
      CC [M]  /tmp/vmware-config5/vsock-only/linux/af_vsock.o
      CC [M]  /tmp/vmware-config5/vsock-only/linux/driverLog.o
      CC [M]  /tmp/vmware-config5/vsock-only/linux/util.o
      CC [M]  /tmp/vmware-config5/vsock-only/linux/vsockAddr.o
      LD [M]  /tmp/vmware-config5/vsock-only/vsock.o
      Building modules, stage 2.
      MODPOST 1 modules
    WARNING: "VMCIDatagram_CreateHnd" [/tmp/vmware-config5/vsock-only/vsock.ko] undefined!
    WARNING: "VMCIDatagram_DestroyHnd" [/tmp/vmware-config5/vsock-only/vsock.ko] undefined!
    WARNING: "VMCI_GetContextID" [/tmp/vmware-config5/vsock-only/vsock.ko] undefined!
    WARNING: "VMCIDatagram_Send" [/tmp/vmware-config5/vsock-only/vsock.ko] undefined!
      CC      /tmp/vmware-config5/vsock-only/vsock.mod.o
      LD [M]  /tmp/vmware-config5/vsock-only/vsock.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-2-686-bigmem'
    cp -f vsock.ko ./../vsock.o
    make: Leaving directory `/tmp/vmware-config5/vsock-only'
    Unable to make a vsock module that can be loaded in the running kernel:
    insmod: error inserting '/tmp/vmware-config5/vsock.o': -1 Unknown symbol in module
    There is probably a slight difference in the kernel configuration between the
    set of C header files you specified and your running kernel.  You may want to
    rebuild a kernel based on that directory, or specify another directory.
    
    The VM communication interface socket family is used in conjunction with the VM
    communication interface to provide a new communication path among guests and
    host.  The rest of this software provided by VMware Server is designed to work
    independently of this feature.  If you wish to have the VSOCK feature  you can
    install the driver by running vmware-config.pl again after making sure that
    gcc, binutils, make and the kernel sources for your running kernel are
    installed on your machine. These packages are available on your distribution's
    installation CD.
    
    Does anybody know what went wrong? Any ideas?

    uname -r returns the right kernel version. I have no idea what this "slight" difference could be.

    Thank you in advance.

    fed
     
  2. fed

    fed New Member

    I finally found a solution for my problem. I had to uninstall an manually delete all vmware related files (like config and /etc/vmware directory).
    Then, I installed the vmware server package but did not ran the config script immediately. First I copied the attached patch und ran

    Code:
    patch /usr/bin/vmware-config.pl /path/to/vmware-config.pl.patch
    Then I called the normal vmware-config.pl and everything worked well. It took some time to find a working patch but this one was working great. Thanks to its writer :)
     

    Attached Files:

  3. falko

    falko Super Moderator ISPConfig Developer

  4. myro

    myro New Member

    thank you fed!!!!
    now it works!!!

    ~# lsmod | grep v
    vmnet 43460 13
    vsock 26032 0
    vmci 52904 1 vsock
    vmmon 72144 0

    :) :)
     

Share This Page