Debian lenny now stable (etch -> lenny)

Discussion in 'General' started by Norman, Feb 15, 2009.

  1. Norman

    Norman HowtoForge Supporter

    So, anyone got any word on if there're any steps to take to make ispconfig run flawlessly for us going from etch to lenny?

    I'm currently testing things out properly on a non-production system before I run any upgrades on packages that arent just security related.
     
  2. till

    till Super Moderator

    I recommend that you wait until the perfect setup for lenny has been released in a few dayys as you might have to redo some configuration steps if the updates overwrites any config files or settings.
     
  3. falko

    falko Super Moderator

  4. pssara

    pssara New Member

    So do you propose we can dist-upgrade our ISPconfig 2.2.latest production servers to Debian 5 (lenny)?
     
  5. till

    till Super Moderator

    Personally I wont do a update so fast after a relaese of a linux distribution. There are updates for etch available for some time so there is no need to hurry, but thats just my personal opibion. If you want to update, do it.
     
  6. AlArenal

    AlArenal New Member

    Done it last night on one of my Etch + ISPC2 machines. I had to manually go through some stuff afterwards as saslauthd didn't work anymore. "adduser postfix sasl" did the trick.

    Also I had to do a "perl -MCPAN -e shell" and "install LWP::UserAgent" and some other stuff as some CPAN modules seemed to be missing after upgrading.

    I'm glad everything works now. Can't wait to mount /tmp und tmpfs to get MySQL creating disk based temporary tables in RAM (until 5.0.48 there's been a bug where those files were created in /var/lib/mysql instead of tmpdir). ;-)
     
  7. Norman

    Norman HowtoForge Supporter

    I'm running the apt-get dist-upgrade on a non-production system that has some users (who know it's testing server) who will get to give me input on how it works out.
     
  8. Norman

    Norman HowtoForge Supporter

    One critical thing that has changed is that php4 isnt supported anymore at all. Just fyi :)
    But this isn't a thing that people who started with etch will notice. They most likely only run php5 anyway.

    apache2.conf wants an update, but "works" with the old config.
     
  9. kanour

    kanour New Member

    Thanks

    Thanks man. You are the man. After I upgraded from Etch to Lenny, my SASL did not worked and I received messages like:

    Code:
    Apr 13 10:46:41 ns0 postfix/smtpd[2984]: warning: SASL authentication failure: Password verification failed
    Apr 13 10:46:41 ns0 postfix/smtpd[2984]: warning: unknown[60.241.247.209]: SASL PLAIN authentication failed: generic failure
    Apr 13 10:46:41 ns0 postfix/smtpd[2984]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    
    After adding postfix user to sasl group "adduser postfix sasl", everything started to work as normal.

    Thank you
     

Share This Page