Debian Lenny - Apache 2.2 VirtualHost - Cannot Find Server

Discussion in 'Server Operation' started by hackenburg, Feb 21, 2010.

  1. hackenburg

    hackenburg New Member

    I'm not sure why my websites will not resolve. My DNS server is resolving fine. In fact, testing ns1.domain.com in a browser resolves the default docroot in Apache. However, as soon as I test domain.com itself, I get "Server not found" error.

    Here is what it looks like:

    <VirtualHost *:80>
    ServerAdmin postmaster@domain.com
    ServerName www.domain.com
    DocumentRoot /var/websites/www-domain.com
    ServerAlias www www.domain.com domain.com
    ErrorLog /var/log/apache2/domain.com-error_log
    CustomLog /var/log/apache2/www.domain.com-access_log combined
    </VirtualHost>


    I am just trying to rebuild my server that needed a new hard drive. I have been running Linux LAMP servers for years and am now trying to figure out Apache 2.2 after mastering 1.3! Any help is appreciated.
     
  2. falko

    falko Super Moderator

    Please check domain.com on www.intodns.com to see if there are any DNS misconfiguration issues.
     
  3. hackenburg

    hackenburg New Member

    Hi,
    Looks like there is something missing according to results. Everything checked out good except these came out with errors:
    • Mismatched NS records
    • DNS servers responded
    • Multiple Nameservers
    • Missing nameservers reported by your nameservers
    • SOA record
    • MX Records
    • WWW A Record

    Here is an example dns config:
    +domain.com:70.66.66.66:10:259200
    .domain.com:70.66.66.66:ns1.domain.com
    @domain.com:70.66.66.66:mail.domain.com:10:86400
    +www.domain.com:70.66.66.66:86400
    +*.domain.com:70.66.66.66.66:86400
    =domain.com:70.66.66.66:864090

    This is the same data file I've used for years (tinydns) and never had any problems. Tinydns is running perfect. What is missing?
     
  4. falko

    falko Super Moderator

    Are your nameservers authoritative for the domain? You can check that by running
    Code:
    dig ns yourdomain.com
     
  5. hackenburg

    hackenburg New Member

    Here are the results of dig ns gomybc.com:

    ; <<>> DiG 9.5.1-P3 <<>> ns gomybc.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7271
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;gomybc.com. IN NS

    ;; ANSWER SECTION:
    gomybc.com. 172800 IN NS ns2.gomybc.com.
    gomybc.com. 172800 IN NS ns1.gomybc.com.

    ;; ADDITIONAL SECTION:
    ns2.gomybc.com. 172800 IN A 70.66.192.231
    ns1.gomybc.com. 172800 IN A 70.66.192.231

    ;; Query time: 33 msec
    ;; SERVER: 64.59.160.13#53(64.59.160.13)
    ;; WHEN: Mon Feb 22 18:12:03 2010
    ;; MSG SIZE rcvd: 96

    Looks like it is good! I've used debian since Woody! Not sure what the big new changes are in Lenny or if it is just my Apache2.2 configuration??
     
  6. hackenburg

    hackenburg New Member

    i just ran cat /service/tinydns/log/main/current and here is the output:

    @400000004b7c4a3e37060964 tinydns: fatal: unable to bind UDP socket: address not available
    @400000004b7c4a5d1dbd49f4 starting tinydns

    netstat -an:
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:56026 0.0.0.0:* LISTEN
    tcp 0 48 192.168.1.103:22 70.66.192.231:30814 ESTABLISHED
    tcp6 0 0 :::80 :::* LISTEN
    tcp6 0 0 :::22 :::* LISTEN
    udp 0 0 192.168.1.103:53 0.0.0.0:*
    udp 0 0 0.0.0.0:68 0.0.0.0:*
    udp 0 0 0.0.0.0:49618 0.0.0.0:*
    udp 0 0 0.0.0.0:616 0.0.0.0:*
    udp 0 0 0.0.0.0:111 0.0.0.0:*

    ps aux:
    root 2477 0.0 0.2 17276 1372 ? Ss Feb20 0:00 /bin/sh /command/svscanboot
    root 2489 0.0 0.0 3824 444 ? S Feb20 0:01 svscan /service
    root 2490 0.0 0.0 3640 348 ? S Feb20 0:00 readproctitle service errors: ...................................................................................
    root 2491 0.0 0.0 3652 388 ? S Feb20 0:00 supervise tinydns
    root 2492 0.0 0.0 3652 388 ? S Feb20 0:00 supervise log
    tinydns 2498 0.0 0.0 3772 388 ? S Feb20 0:00 /usr/local/bin/tinydns
    dnslog 2499 0.0 0.0 3664 380 ? S Feb20 0:00 multilog t ./main

    There are no errors and the netstat shows port 53 listening??? I'm not sure if the "unable to bind UDP socket" is a new error. ARRGGHHH!?@?!
     

Share This Page