Debian Lenny 5.0.7 w/ Areca RAID install issues

Discussion in 'Installation/Configuration' started by drewb0y, Dec 6, 2010.

  1. drewb0y

    drewb0y Member

    I have been trying to install debian 5.0.7 amd64 on a Rackable Systems Dual AMD Opteron server which has an Areca ARC-1110 hardware RAID controller installed. I have 2 250GB drives configured as RAID 1. The debian install saw it as only one drive, just as it should. Install went smoothly, but on reboot, the system would not load.
    I did some research and tried a couple of things with no luck. Like adding a rootdelay in the grub command. It juts sits at "loading system" for a while then times out and loads busy box.
    Just to check things out, I booted into an Ubuntu live-cd and mounted the volume. The file system is there and all of the necessary files. I am sure the issue is that the arcmsr module is not being loaded by the kernel on boot.

    I found some instructions related to getting these cards working in Debian by making a custom installer, but those were for debian 3 and seriously outdated.

    I have the already compiled acrmsr.ko file taken from the scsi-extras-modules udeb. I have been able to load it successfully in a vmware test environment using insmod.

    I am really not sure where to go from here. Why does the install see the disk fine and then not load? Why is it that Ubuntu server installs fine as well as CentOS?

    How do I get Debian to work with this hardware? I really don't want to have to switch distros. Everything I have worked on already is in debian.

    Thanks in advance for any advice!
  2. Norman

    Norman Member HowtoForge Supporter

    This isnt really a perfectsetup issue.
    This is more to do with your raid not being recognized or that grub doesnt properly get the right paths to root partition hd0,0 .

    I can however help you if you give me the exact fail message.
    And the definiton of your disks in the grub menu.lst file.

    It might also be the module not loading as you say but that is more a Debian question. My guess is however that the paths arent proper in menu.lst , this has happened to me on occasions. In my case I had a remote management card with virtual cdroms that later got unmounted. The USB order switched around /dev/sda for /dev/sdb etc.
    Last edited: Dec 8, 2010
  3. drewb0y

    drewb0y Member

    I agree that it's nothing wrong with the perfect setup at all, just a debian issue. I will post my grub entries shortly. It's just frustrating to me that I have been able to install several other operating systems and distros with no issues whatsoever. I did also post to the with no response there yet. I do know that there is a way to make this work. Especially if Ubuntu server works, and it is based on debian.

    Thanks for the help.
  4. drewb0y

    drewb0y Member

    More information

    Okay, so here's what I get so far... hopefully this will help us figure this out.
    The one thing that does stike me as odd here is that in /dev it shows an sda, while on install it creates the partition on sdb

    Error message on boot

    Loading, please wait...
    Gave up waiting for root device. Common problems:
     -Boot args (cat /proc/cmdline)
      -Check rootdelay= (did the system wait long enough?)
      -Check root= (did the system wait for the right device?)
     -Missing modules (cat /proc/modules; ls /dev)
    ALERT! /dev/sdb1 does not exist. Dropping to a shell!
    results of cat /proc/cmdline

    root=/dev/sdb1 ro quiet
    results of cat /proc/modules

    sr_mod 19652 0 - Live 0xffffffffa0109000
    cdrom 37928 1 sr_mod, Live 0xffffffffa00fe000
    usb_storage 95936 0 - Live 0xffffffffa00e5000
    sd_mod 29376 0 - Live 0xffffffffa00dc000
    sg 36448 0 - Live 0xffffffffa00d2000
    ide_pci_generic 9220 0 [permanent], Live 0xffffffffa00ce000
    tg3 97156 0 - Live 0xffffffffa00b3000
    arcmsr 25856 0 - Live 0xffffffffa00ab000
    ohci_hcd 25092 0 - Live 0xffffffffa00a1000
    amd74xx 13448 0 [permanent], Live 0xffffffffa009a000
    ide_core 128284 2 ide_pci_generic,amd74xx, Live 0xffffffffa0079000
    ata_generic 10116 0 - Live 0xffffffffa0075000
    libata 165600 1 ata_generic, Live 0xffffffffa004b000
    scsi_mod 161016 6 sr_mod,usb_storage,sd-mod,sg,arcmsr,libata, Live 0xffffffffa0022000
    dock 14112 1 libata, Live 0xffffffffa001d000
    thermal 22688 0 - Live 0xffffffffa0016000
    processor 42304 1 thermal, Live 0xffffffffa000a000
    fan 9352 0 - Live a0006000
    thermal_sys 17728 3 thermal,processor,fan, Live 0xffffffffa0000000
    results of ls /dev/sd* (at this point I did still ahve the external USB DVD-ROM drive that I installed from connected)

    /dev/sda /dev/sda1 /dev/sda2 /dev/sda5 /dev/sdb
    Not sure if this is relevant, but this is from the BIOS of the RAID card displayed while booting

    And last but not least, my /boot/grub/ and /boot/grub/menu.lst contents

    (hd0) /dev/sdb
    menu.lst (the important parts anyway)

    title  Debian GNU/Linux, kernel 2.6.26-2-amd64
    root  (hd0,0)
    kernel  /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sdb1 ro quiet
    initrd  /boot/initrd.img-2.6.26-2-amd64
    title  Debian GNU/Linux, kernel 2.6.26-2-amd64 (single-user mode)
    root  (hd0,0)
    kernel  /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sdb1 ro single
    initrd  /boot/initrd.img-2.6.26-2-amd64
  5. drewb0y

    drewb0y Member


    Man do I feel stupid now. Your idea of USB order was exactly correct. Just for grins, I decided to reboot with the external USB DVD-ROM disconnected this time. Of course it still failed as before...but when i did the ls /dev/sd* command this time there was no sdb. So it was mounting the dvd as sdb. Why the installer and the actual installed system would reverse each other like this, who knows.

    So I edited the file and changed sdb to sda.
    Same thing with the menu.lst.
    Rebooted, and voila!

    I spent days and countless tme doing fruitless google searches, and it turns out I was looking for the wrong answers. It wasn't the RAID at all, it was the external USB that threw it all off!

    Thanks again, Norman.

    Now to fix the IOMMU error and then I can get this baby ready for production.
    Last edited: Dec 8, 2010

Share This Page