Debian Jessie upgrade kernel problem

Discussion in 'Kernel Questions' started by gpetrom, Oct 17, 2015.

  1. gpetrom

    gpetrom New Member HowtoForge Supporter

    Hi

    I have a fresh debian jessie installation on kvm host. When i am trying to ugrade debian jessie i get the following error.
    Code:
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up linux-image-3.16.0-4-amd64 (3.16.7-ckt11-1+deb8u5) ...
    /etc/kernel/postinst.d/initramfs-tools:
    update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64                                                                                                                                                  
    /etc/kernel/postinst.d/zz-update-grub:                                                                                                                                                                        
    Segmentation fault
    run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 139
    Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.16.0-4-amd64.postinst line 634.
    dpkg: error processing package linux-image-3.16.0-4-amd64 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    linux-image-3.16.0-4-amd64
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Has anyone experienced such an issue and how can i solve that?

    Thanks
     
    daipaahmed likes this.
  2. gpetrom

    gpetrom New Member HowtoForge Supporter

    Hi
    Some information that may help
    Sources
    Code:
    deb http://ftp.gr.debian.org/debian/ jessie main contrib non-free
    deb-src http://ftp.gr.debian.org/debian/ jessie main contrib non-free
    
    deb http://security.debian.org/ jessie/updates main contrib non-free
    deb-src http://security.debian.org/ jessie/updates main contrib non-free
    
    # jessie-updates, previously known as 'volatile'
    deb http://ftp.gr.debian.org/debian/ jessie-updates main contrib non-free
    deb-src http://ftp.gr.debian.org/debian/ jessie-updates main contrib non-free
     
    daipaahmed likes this.
  3. gpetrom

    gpetrom New Member HowtoForge Supporter

    Hi

    Problem solved

    I removed grub and installed it again and now is updating ok. [​IMG] apt-get remove grub-common
    Code:
    apt-get remove grub2-common
    apt-get autoremove
    apt-get update
    apt-get upgrade
    apt-get install grub-common
    apt-get install grub2-common
    grub2-update
    apt-get autoremove removed libfuse2 and os-prober that was left after i removed grub-common. I do not know if that was necessary but after i removed them i did not have any errors when i was trying to upgrade.
     
    daipaahmed and till like this.

Share This Page