Debian Jessie, multiple PHP versions, remove default PHP?

Discussion in 'Installation/Configuration' started by snowfly, May 16, 2016.

  1. snowfly

    snowfly Member

    Running latest, multiserver, setup a new debian jessie server, with php fpm, and installed multiple PHP versions: 5.3, 5.4, and 5.6, using guides like this:

    Is it recommended, or ok, to remove the default debian jessie package for PHP5 (5.6.20-0+deb8u1) and default php5-fpm scripts, and all sites just use one of the compiled multiple PHP versions?

    Or is it best to leave default PHP there, so things like ispconfig cron tasks can still use default php cli?

    Ideally I would like to limit clients to only use one of the defined multiple PHP Versions (5.3/5.4/5.6), so in the future if the server is dist-upgraded, users can remain on their desired PHP version.
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You should _never_ change the php-version shipped with your os.
  3. snowfly

    snowfly Member

    Please elaborate?
    If you say that, why are there guides to install multiple PHP versions on an ISPConfig server, allowing clients to select the PHP version they wish when adding a site?
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    mutiple php-version are for the websites. this does not affect the php-version from your server.
  5. snowfly

    snowfly Member

    Ok thanks, you had me worried for a moment there, but makes sense, will leave default PHP as is.

Share This Page