Debian Jessie: error on SuExec disabled (solved)

Discussion in 'General' started by claudioimai, Jan 25, 2016.

  1. claudioimai

    claudioimai New Member

    Hello, I was looking for this answer but could not find anywhere besides a fix for OpenSUSE, but some details were different, so I decided to post the details to fix this error on Debian 8 + ISPConfig3:

    Error: Apache does not load, got the error "suEXEC is disabled: Invalid owner or file mode for /usr/lib/apache2/suexec" by issuing the command
    Code:
    systemctl -l status apache2.service
    Fix (for my system, at least):

    Code:
    chown root /usr/lib/apache2/suexec-pristine
    chmod 4754 /usr/lib/apache2/suexec-pristine
    (/usr/lib/apache2/suexec is a symlink to /usr/lib/apache2/suexec-pristine, therefore the change was made to the real file)
    Hope it will save someone a few minutes ;-)
    Cheers!
    Claudio H. Imai
     

Share This Page