[debian] Freeradius with MySQL and daloradius ?

Discussion in 'HOWTO-Related Questions' started by GHz, Jul 23, 2009.

  1. awan

    awan New Member

    SSL n stuff


    vi /etc/freeradius/radiusd.conf & comment the following line.

    $INCLUDE eap.conf

    Note: Make sure u turn the corresponding ssl requiring authentication methods OFF in /etc/freeradius/sites-enabled/default

    btw this tutotial although centos 5 centric but it still explains the non-ssl non-mysql testing on ur freeradius server as well.


    furthermore this link illustrates using the same with ubuntu/debian distro.


    And yeah do check the privileges on the certificates/folder (it should belong to freeradius user (check out /etc/password for that). I think it should fix the ssl error thingy. Cheers

  2. GHz

    GHz New Member

    Thanks awan for your quick reply. I will try it this afternoon :) and I'll let you know if it worked.
  3. GHz

    GHz New Member

    It works! Now going to test it :). I'll make a howto if it is really working :)


    Hmm, not completely, I get DB errors about tables which don't exist :(
    Last edited: Nov 6, 2009
  4. GHz

    GHz New Member

    I just imported the daloradius and freeradius SQL file to see if that made any difference, but the problem is still there. It still tells me that some tables do not exist. CAn anyone help me with this? Thanks!

    Last edited: Nov 6, 2009
  5. awan

    awan New Member

    schema issues !

    hey there,
    I had uploaded a changed/updated version of schema on that howto (within the howto). Use that.

    Btw also make sure u have set the right privileges on the DB/schema.

    Note: I wrote this howto with the version of the softwares used mentioned in the howto. Other than that I do not guarantee it would work. Letme know though.
  6. norrafi

    norrafi New Member

    I still get no response server. Do you think NAS-IP-Add should be

    Last edited: Nov 19, 2009
  7. norrafi

    norrafi New Member

    But when I change localhost to; I got;

  8. awan

    awan New Member

    newbie blunder ?

    hmm. Judging by ur TCP/IP/subneting concepts I am not sure you are cut out for this stuff. U should know better 127.x.x.x is a special subnet.

    Anyway whatever is you IP address (not the loop back address) set the IP for that NAS device from within that subnet & try again.
  9. norrafi

    norrafi New Member

    Success on MYSQL-Freeradius part,
    but 2 more problem;
    1- dolarius 0.9.8 get error after login(access from localhost);

    2- the login page cannot appear from other client/ip;

    I already follow this;
    chown www-data:www-data /var/www/daloradius -R
  10. norrafi

    norrafi New Member

    Success for no2, I make changes on apache2.conf. add below line;


Share This Page