Debian Etch parsechangelog/debian: error: badly formatted heading line

Discussion in 'Kernel Questions' started by azzo, Dec 11, 2007.

  1. azzo

    azzo New Member

    Hi all!
    First of all, i am a newbie, but, since i have fairly new hardware i had problems running the etch 2.6.18 vanilla kernel and started to customize it. recompiled it a few times, destroyed the mdr, crashed everything, but, at the end, i have a fully booting/working/serving machine. Now since my kernel has grown quite big i would like to modularize it. here comes the problem:
    before this last attempt i have used make-kpkg, following the instruction from
    but i have tried the simple make/make install (which did not worked for me) too, before, resulting in an unusable initrd image.
    well: yesterday the make-kpkg / dpkg resulted in a perfect build/install, today issuing
    fakeroot make-kpkg --initrd --append-to-version=-teps01 kernel-image kernel-headers
    gave me
    Warning: The file include/linux/version.h exists
    The contained UTS_VERSION string:
    does not match expectations:
    I'll try and recover
    exec debian/rules  DEBIAN_REVISION=2.6.18-teps01-max_mod-10.00.Custom  APPEND_TO_VERSION=-teps01  INITRD=YES  kernel-image kernel-headers
    parsechangelog/debian: error: badly formatted heading line, at file debian/changelog line 1
    i've tried to add a line in /usr/src/linux.etcetera/include/linux/version.h
    #define UTS_VERSION 2.6.18-teps01
    but nothing changes.

    i cant explain why yesterday it worked and today not.
    well, the only thing it occurred in the meantime is the removal of vmware (sever, client, mui) and the reinstall of the server only.

    also i'd like to know what should i do to uninstall the other kernels i built and i dont need anymore.

    any suggestion appreciated.

    thanks in advance/sorry for approximate english
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install them using dpkg? Then you can use dpkg to uninstall them as well. See
    man dpkg
  3. azzo

    azzo New Member

    half job done...

    thanks falko,
    the kernels i installed with dpkg i can successfully remove with
    dpkg -P --force-remove-essential linux-image/headers-xxx
    i got the names of the installed kernels by means of
    dpkg -l | grep linux
    but the kernels i installed with make install i cant figure out how to uninstall without, perhaps, messing up the system.
    I imagine i should delete the config-xxx, initrd.img-xxx,, vmlinuz-xxx from /boot and xxx from /lib/modules but then? is that enough?

    thanks again,
  4. azzo

    azzo New Member


    i dont know why, but reinstalling build-essentials and kernel-package
    apt-get remove build-essentials kernel-package 
    apt-get install build-essentials kernel-package
    and then unpacking again the linux-source, copying the .config i devised made the build possible. simply reunpacking the source didn't solve.

    hope people with the same problem will find this useful.

    Still, if anyone knows how to clean well a non-dpkg install, ill be glad to know!

Share This Page