Debian container not starting

Discussion in 'General' started by mrbronz, Apr 27, 2012.

  1. mrbronz

    mrbronz New Member

    Hi to all

    I moved my server's to Debian, so that I could utilizes the openVZ kernel.

    I have managed to install ISPConfig 3 and it all seems to be working.

    I have also managed to create a virtual server using a Ubuntu template via ISPConfig 3.

    Now the problem is I also attempted to create a Debian container, However this container fails to initialize.

    Seeing as I am experimenting with this setup, to see how it works, I don't have a clue whats wrong or where to start looking.

    Any help or advice would be appreciated.
     
  2. till

    till Super Moderator

    Please post the file /etc/fstab
     
  3. mrbronz

    mrbronz New Member

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sdc1 during installation
    UUID=73c2cc89-4e5c-4606-9b3e-8965f06a9e48 /               ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       1
    # swap was on /dev/sdc5 during installation
    UUID=fa68f448-cc56-4d2e-917e-a9d1ddfe037e none            swap    sw              0       0
    #/dev/sdb1       /media/usb0     ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       0
    /dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
    /dev/sdc1       /media/usb1     auto    rw,user,noauto  0       0
    /dev/sdc2       /media/usb2     auto    rw,user,noauto  0       0
    /dev/sdb5       /media/usb3     ext3    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       1
    ~                                                                                                     
    I think you may need to see my fdisk -l as well

    Code:
    Disk /dev/sda: 2000 MB, 2000388096 bytes
    255 heads, 63 sectors/track, 243 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00081cfe
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1          13      104391   83  Linux
    /dev/sda2              14         243     1847475   8e  Linux LVM
    
    Disk /dev/sdb: 32.6 GB, 32614907904 bytes
    255 heads, 63 sectors/track, 3965 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x000bb206
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        3843    30860288   83  Linux
    /dev/sdb2            3843        3966      987137    5  Extended
    /dev/sdb5            3843        3966      987136   82  Linux swap / Solaris
    
    Disk /dev/dm-0: 1040 MB, 1040187392 bytes
    255 heads, 63 sectors/track, 126 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/dm-0 doesn't contain a valid partition table
    
     
  4. falko

    falko Super Moderator

    Do you get any errors when you try to start the VM?
     
  5. mrbronz

    mrbronz New Member

    remount error

    Hi Falko

    No I didnt get any errors when starting the vm but i just tried to run

    Code:
    mount -o remount /
    again and get

    Code:
    mount: permission denied
    I'm still cluless !
     
    Last edited: Apr 28, 2012
  6. falko

    falko Super Moderator

    Have you tried to reboot?
     
  7. mrbronz

    mrbronz New Member

    Yes I rebooted

    But still not go

    I just looked into /vz/private and the direcory in not being created
     
    Last edited: Apr 29, 2012
  8. till

    till Super Moderator

  9. mrbronz

    mrbronz New Member

    Hi there

    Yes I did the same as what i did for the Ubuntu template which is working with no problems, but the Debian is not initializing.
     
  10. mrbronz

    mrbronz New Member

    Bump

    Any help please
     
  11. till

    till Super Moderator

  12. voidzero

    voidzero New Member

    I am trying the very same thing -- same issues. In the logfile is "Container config file does not exist". No container is being made.

    *edit* The container config file message is when I tried to start it. So logical, because no container was setup... I have no idea how to fix this, please give me suggestions...
     
  13. voidzero

    voidzero New Member

    This does nothing helpful by the way. You see "/usr/sbin/vzctl" or not even that. Setting ispconfig's logging to debug does nothing interesting.

    What is ispconfig trying to do when it creates the VM? I would try the commands manually but.... I would need to know what they are. It would also help to know what ispconfig puts into the database so that I know which VZ config it should use.

    Sorry, it's been two days so am a bit annoyed, but please don't read this in the wrong way. Maybe there is a bug somewhere. I did follow every step described in http://www.howtoforge.com/installing-openvz-plus-management-of-vms-through-ispconfig-3-debian-6.0. The only difference is that I am using nginx instead of apache. But with years of ISPConfig 3 experience (except for OpenVZ) I got that to run smoothly.

    So let's hunt it down? :)

    (in fact, just now I subscribed as a supporter because of all the help and dedication from Till and Falko. I should have done that earlier. hopefully more people will subscribe, it's really worth it.)
     
    Last edited: Jun 16, 2012
  14. voidzero

    voidzero New Member

    Found it! I installed ispconfig and then rebooted to the openvz-capable kernel. So what I had to do was...

    Code:
    cd /usr/local/ispconfig/server/plugins-enabled
    ln -s /usr/local/ispconfig/server/plugins-available/openvz_plugin.inc.php
     

Share This Page